WSL 2 Backend has stopped unexpectedly


I’m new with Dockers. I’m joining an Academy where teacher is working on Docker and asked us to install and use it.
I Have to create containers from here GitHub - big-data-europe/docker-hadoop: Apache Hadoop docker image but when I launch the command “docker-compose up” on CMD the installation starts working and after 146.9s stops, almost everytime.
I’ve tried to uninstall docker, I’ve tried “wsl --unregister docker-desktop” but anything isn’t working: I’m always stuck with the same message in the object of this topic shown in Win 10 notification.

My PC has win 10 and 8 gb RAM.
I’ve tried one tutorial advised in the software and everything works fine…

Thanks in advance for your patience and support.

The error message in the topic title and the fact that the sercices started by docker compose stop can be two different issues.

  • Have you tried to run a WSL distribution without Docker Desktop?
  • Have you checked the error messages bí running docker-compose logs before WSL2 stopped?
  • Is it possible that you don’t have enough space on your machine or inside WSL?

You can try this troubleshoot guide to get more information:

There is a similar issue here?