WSL2 preventing other programs from using computer virtualization

When installing docker, other emulators installed on the computer will no longer be able to use the computer’s virtualization. even with docker desktop closed. When you uninstall docker everything goes back to normal.
Can anyone help?
Captura de tela 2024-03-01 115015

Press WIN+R type “cmd” and press Enter to open a console.

Then run the commands “wsl --version” and “wsl --list --verbose”. Can you post the output?

Versão do WSL:
Versão do kernel:
Versão do WSLg: 1.0.59
Versão do MSRDC: 1.2.4677
Versão do Direct3D: 1.611.1-81528511
Versão do DXCore:
Versão do Windows: 10.0.26058.1400

=============== # =============== # ========================


  • docker-desktop-data Stopped 2
    docker-desktop Stopped 2

The simultaneous operation of WSL2 and LDPlayer is not supported by LDPlayer.

But you can try to disable the use of WSL2 in the Docker Desktop settings.
Does the LDPlayer then work?

When I disable wsl in docker it still has the same problem in ldplayer

if hyper-v components are installed (Hyper-V installs it fully, WSL2 a lighter version of it), they will claim the cpus virtualization flag, so other virtualization solutions can’t use it. Docker Desktop depends on either one of them.

vmware and virtualbox should run in a hyper-v compatibility mode (unless they are very old version). It will be way slower than before, but it should work if you configure your vm to not use vt-d or hardware virtualisation.

1 Like

Thanks for the explanation.
But if I have understood correctly, the LDPlayer does not run without it.

Some people disable Hyper-V to use LDPlayer , and re-enable it to use Docker… a bit strange but very pragmatic

I didn’t know what LDPlayer is. Google says It is an android emulator, and it bases on VirtualBox in a headless mode. VirtualBox itself is known to work with hyper-v compatibility mode, but it will give you the infamous “green turtle” icon in the bottom status bar, which indicates that hardware virtualization is not used.

Since WSL2 arrived, I stopped using vm emulators, as it runs everything I need (including ui applications)

The error message in the image posted by wevertonribeiro comes from LDPlayer (Reverse Image Search helps)

I also found this in relation to the error message:

Turn off Memory Integrity in Windows Security is also not a good idea.

I can’t help with it, but from your posts I assume that LDPlayer does not provide an option to turn off hardware virtualization, so that it does allow making the embedded VirtualBox use the built-int hyper-v compatibility mode. Hence, your workaround of disabling the hyper-v feature.

Docker Desktop itself is not the cause of the situation, it is affected by the dependency to the virtualization platform it uses to run its utility vm that runs the Docker Desktop backend.

This is a problem amongst hyper-v/wsl-2 and the virtualization solution that doesn’t play nice with them. I am surprised that someone even releases a virtualization solution for Windows that does not allow to be run in hyper-v compatibility mode. This situation exists since a couple of years now and is nothing that happened overnight.

Personally, I would look for a solution that can run inside a wsl2 distribution, like

1 Like

I just remembered there is a Windows Subsystem for Android:

1 Like

Now Microsoft has announced that support for the Windows Subsystem for Android™ (WSA) will be discontinued on March 5, 2025 :frowning: