App freezes and mac reboots (endless bootloop)


Just wanted to let you know my issue. After updating to latest Docker version, my pc freezes and reboots when app is started.

  • Issue type: bug
  • OS Version/build: MacOS Monterey 12.2, Apple chip.
  • App version: 4.23.0
  • Steps to reproduce:
    • Open Docker Desktop app
    • Wait 3 seconds
    • Mac reboots
    • On next boot, as soon as app starts, this happens again. Endlessly, until you uninstall the app.

PS: After downgrading to v 4.0.0 there are no issues.

1 Like

I’m having the exact same issue.
Also reproducible in safe mode, all is fine until I start docker desktop.
Tried reinstalling, but same issue.

Version 4.22.1 works fine.

Thank you for sharing it so macOS users can be more careful before upgading Docker Desktop, but if you want to let the Developers know about it, you can share it on GitHub:

I’ve just updated to v4.23.0 on my Mac m1 to see if it restarts my Mac, but it worked without any issue. My Mac is MacOS Ventura 13.5. Without the latest update, because I wanted to see if worked before that. So the issue could be related to older macOS versions.

@sandervdlindenenovationgroup what was your macOS version?

Thanks for trying it out! I’m still on Monterey 12.5 indeed.
I’ll update it soon to verify if that solves this issue.

Indeed updating MacOS worked, in my case updated to Sonoma 14.0 and could update and use docker desktop to 4.23.0 without issues.