Docker desktop is stopped on Mac M1 Monterey

Hi, Docker Desktop 4.24.0 is stopped after being upgraded.
I’ve tried couple things but still not working.
Remove

rm -rf Library/Group\ Containers/group.com.docker
rm -rf Library/Containers/com.docker.docker
rm -rf Library/Application\ Support/Docker\ Desktop

Change “filesharingDirectories”: in ~/Library/Group\ Containers/group.com.docker/settings.json

Also tried force quit eveything related to Docker.

Still Docker Desktop is stopped.

Any ideas?

This seems related

I just updated to Docker Desktop 4.24 without issues on my Mac. Unfortunately I have no idea why it happens. If you want to try to properly reinstall Docker Desktop, you can watch my video which already help many users

Thank you for response.
I’ve watched the video before ask question but didn’t solve the issue(Complete uninstall)

Solved issue by upgrading Monterey 12.112.7 version.

So it seem in your case your Mac was too old or at least something changed during the upgrade that affected Docker Desktop…Thank you for your feedback.

1 Like

I am also following the same issue, I removed the Docker from my machine completely as shown in the video, however when I reinstall , it again shows the same issue. And the error is Docker Engine has Stopped.
I am not sure how to start it again

System: macOS Monterey Apple M1 Pro chip

Then you probably missed something since the video was made for an older Docker Desktop just to give some ideas. Whe the engine stops that is probablycaused by an incorrect daemon configuration. Don’t forget to remove $HOME/.docker

I don’t think I mentioned in the video, since I didn’t need to reboot my Mac, but that also helps sometimes before reinstalling Docker Desktop.

Thank you rimelek for the quick response, however, I upgraded my MacOs to version 14 MacOS Somana., and now docker works fine.

1 Like

Thanks for following up with your solution. I was in the exact same situation and got the exact same result. What a relief, I depend on Docker these days!

i upgraded my Os from Monterey to Somana. It worked

1 Like

Just in case someone is wondering what version you updated to, you probably meant “Sonoma” not “Somana” :slight_smile:

I tried your approach. It works for me too. Thanks a bunch!

Thank you for your thread. My docker was dead for months and I tried reinstalling it / resetting factory settings multiple times, nothing worked.

Don’t forget to remove $HOME/.docker

I deleted .docker and now it’s all working! Can’t imagine why resetting factory settings doesn’t nuke that folder…

Thanks again!

Because it is for client settings and you could use the same client for many remote or local Docker installations like manually configured remotes or Rancher Desktop and Podman Desktop. So Docker Desktop could try to remove files and setings that can be indentified as 100% created by Docker Desktop. It either doesn’ do that or can’t always be perfect.