Docker Community Forums

Share and learn in the Docker community.

Are volumes supposed to work?


(Tehes) #1

Expected behavior

As shown in the “settings”->“manage shared drives” section, the “docker run -v c:/Users:/data alpine ls /data” example should list all my folders/files in C:\Users

Actual behavior

I have 10 folders in C:\Users and only 1 is displayed when I run “docker run -v c:/Users:/data alpine ls /data”.
If I create more folders in C:\Users and run the docker command again, they are not listed…

Information

Windows 10 Pro 1511, 10586.104
Docker 1.11.0-beta8 (build 1832) d26fe3c

Steps to reproduce the behavior

Go to “Settings”->“Manage shared drives”, and enable the share on C
Run the example: docker run -v c:/Users:/data alpine ls /data


(Streetmapp) #2

Double check that the “Manage shared drives” setting is still checked.

I know I was running into similar issues, wondering if it worked or not and found the setting as described. Upon checking it off, things worked. However was running through the examples again after reading your post and was seeing the same behavior. It turns out that the setting actually got unchecked on me.