Docker container is created but unable to start

The Docker Desktop for Windows community forum is place where users can meet and discuss Docker Desktop for Windows and related technologies.
If you encounter problems with Docker for Windows, we recommend:

Finally, if your issue has not been addressed elsewhere, running:

  • :whale: :arrow_right: Settings :arrow_right: Diagnose & Feedback :arrow_right: Open Issues.

This forum is not an official product support or issue reporting channel.

Hello everyone.

I have an issue and we would like to ask you for help.

The issue is described as follows:

Windows Containers cannot be started on Windows Server.

Containers can be created successfully though. Once the container is created, it cannot start and just hangs up forever.

I have tried to start them by console commands and Docker API to no avail.

Oddly enough, Linux containers can be created and started with no problems on the same machine.

Environment Specs:
OS: Windows Server 2019 DC
Docker Server version: 19.03.5
Docker Desktop Version: (community)

What have we tried so far?

We are behind a corporative antivirus called Symantec. We have tested on the same machine after uninstalling Symantec and everything works as charm. So we know for sure is something related to Symantec. We are enforced to use Symantec in production environment, so left it uninstalled is not an option. Currently, we have added to exceptions the following paths:

C:\Program Files\Docker
C:\Program Files\Hyper-V

But it isn’t working yet.

Do you know the specific processes we need to add to exceptions for windows containers to be able to start?

Is there anything else we should configure on Symantec for them to run successfully?

Thanks a lot for your help.