Docker Community Forums

Share and learn in the Docker community.

Boot2docker, Docker-compose and memached container


(Freiden) #1

I’m beginning to look to docker on OSX via boot2docker and
docker-compose by trying to connect containers from the official library
to a rails app (following the steps described in Docker documentation
on the subject).

While mysql, redis and other containers doesn’t bothered me, I can’t
find a way to make the memcached container work (using the official or
others containers listed in Docker Library).

After the container creation message I have the following one:

Couldn’t connect to Docker daemon - you might need to run boot2docker up.

When using docker-compose ps command, the state displayed is: Exit 0.

If I execute the command and retry to build the container the same message appear.

I tried this on 2 computer and I’m having the same problem. Tried
with the official boot2docker package and Homebrew version likewise.

Am I missing something when creating the memcached container?