Docker Community Forums

Share and learn in the Docker community.

Cannot enable hyper-v service

The Docker Desktop for Windows community forum is place where users can meet and discuss Docker Desktop for Windows and related technologies.
If you encounter problems with Docker for Windows, we recommend:
i try to instal Docker Desktop (45183 on window 10 Pro versio 1909

Error message “cannot enable hyper-v service”

Any help would be apreciated

Finally, if your issue has not been addressed elsewhere, running:

  • :whale: :arrow_right: Settings :arrow_right: Diagnose & Feedback :arrow_right: Open Issues.

This forum is not an official product support or issue reporting channel.

1 Like

Try to enable virtualization in BIOS.


Enabling virtualization worked for me, thanks mate

My machine already enabled the Hyper-V and still cannot start docker… My Windows and Docker are at the latests updates…


Try this

Run bcdedit /set hypervisorlaunchtype auto as Administrator in cmd.

This worked for me, ensure the hyper-v is enabled in your BIOS aswell.

1 Like

Right click on the Windows button and select ‘Apps and Features’.
Select Programs and Features on the right under related settings.
Select Turn Windows Features on or off.
Select Hyper-V and click OK.

1 Like

Enabling virtualization from BIOS worked out for me as well. Thanks!

1 Like

DockerDesktopVM failed to start is driving me crazy. My work computer is a windows 10 and works perfectly installing Docker Desktop… but my personal computer will not start: BIOS virtualization is ON, Hyper-V is enabled… but when my docker starts linux containers… ERROR.

Please HELP!!!
thanks so much

During instalation of docker I checked enable Hyper-V. And after restart my computer. I got popup with that "Error occured: Cannot enable hyper-v service"
I checked that I have enabled Hyper-V and virtualization in BIOS.

So I did disabl/enable Hyper-V every time with system restart

More concrete steps:

  1. got to ‘Apps and Features’.
    Select Programs and Features on the right under related settings.
    Select Turn Windows Features on or off.
    Unselect Hyper-V and click OK. (So I disable it)
    Restart computer

  2. After restart I go to:
    ‘Apps and Features’.
    Select Programs and Features on the right under related settings.
    Select Turn Windows Features on or off.
    select Hyper-V and click OK. (So I enable it)
    Computer restart

After restart, docker worked correcly :slight_smile:
I restart my computer few times before that way. I reinstall docker desktop few times…
After every select/unselect Hyper-V during restart process windows looks like during upgrade process…


I am also stuck in the problem getting the error “Cannot enable Hyper-V service”…
I turned on Hyper-v in Bios and windows apps and feathers
I also unselected and selected the Hyper-v
but still the error comes to me…

It worked
God bless you

you can enable Virtual machine platform
on Apps and Features
with Select Turn Windows Features on or off

Of course, I already did it. but no effect.
Maybe I think my problem comes from the cause of AMD CPU(Ryzen 5 2600), because docker works very well on my other intel i5 computer (same OS, win10 ver 1903)
I figured out hyper-v manager doesn’t installed when I enable the Hyper-v service in Windows Features and restart. I don’t know why that manager didn’t installed.

@mituramikolaj Works for me, thanks!

Same issue. Cannot enable Hyper-V service

Hyper-V is enabled

Windows 10 Enterprise v1809
Build 17763.1282
Intel i5-6200U

Docker desktop

I got stuck with the same issue "Error message “cannot enable hyper-v service”. With the reference of above suggestions these steps helped me
1. Restart, in BIOS settings, enable virtualization features [ press ‘Esc’, ‘delete’ or F10 depends on your HW, go to BIOS settings -> Advanced -> device settings -> select virtualization checkbox(s) ]
2. As described here enable Hyper-V all checkboxes
3. Restart the system and then run the docker - you should be all set!

Enabling Virtualization worked for me.
Thank you

  • Update Bios and later in settings, enable virtualization features.
  • in app & features -> programs $ features Enable Hyper-V and DISABLE Virtual Machin Plataform and Windows Hypervisor Plataform (those options could give you conflicts).
  • Check in windows services if Hyper-V Host Compute Service and Hyper-V Virtual Machine Management are running.

It Worked for me.

I realize its an old thread but just want to put out what fixed mine. I had ubuntu as a dual boot with my windows 10. As soon as I removed grub and ubuntu, I could enable hyper-v easily. I think temporarily disabling grub would work fine instead of removing it like I did.

On my Windows 10 Enterprise 1803, with Docker Desktop, I was getting the same error again and again when starting Docker Desktop: “cannot enable hyper-v service”.
Windows Hyper-V features all enabled, BIOS okay.
The I kept that dialog open, and checked the dockers icon in the system try: I could use it’s the context menu and switch to windows containers! It was by default on linux container, the installer is not asking that…
After that: closed that error dialog and started docker desktop again -> works now.

1 Like