Docker Community Forums

Share and learn in the Docker community.

Sometimes Docker fails silently to enable Hyper V


(Marc1404) #1

Expected behavior

Docker should enable Hyper V when I click “Install & Restart” upon the Hyper V prompt.
It should tell me in case it was unable to enable Hyper V.

Actual behavior

Some time passes without a progress indicator.
An error message will pop up which says some constructor belonging to Hyper V could not be found.
(Instead it should say: “Hey, I could not enable Hyper V for you. Here are the manual steps to do it yourself.”)

Information

  • Windows 10 Pro
  • Docker Version 1.11.1-beta12 (build: 3073)

Steps to reproduce the behavior

  1. Install Docker
  2. Let it enable Hyper V & Restart (works)
  3. Uninstall Docker
  4. Disable Hyper V via Windows Feature Settings
  5. Install Docker and let it try to enable Hyper V (did not work)

(I know this is some weird kind of edge case but I wanted to report it anyway, maybe it is useful.
Fix: I had to enable Hyper V in the Windows Feature settings myself.)


(Jeremy Keen) #2

Same error in Windows 10 when installing Docker for Windows. See screenshot.


(Michael Friis) #3

Thanks for reporting, we’re working on a fix.


(Motu) #4

Worked for us, thanks


(Elendrys) #5

Had the same issue. I enabled HyperV manually and docker ran fine. But it says it’s supposed to be done by the software.


(Harro van der Klauw) #6

Had the same, the issue for me was the virtualization was disabled in the bios disallowing the activation of Hypersupervisor