Docker Community Forums

Share and learn in the Docker community.

Cannot enable hyper-v service

works for me, thanks

I’d recommend switching to WSL2 assuming you can upgrade to Windows version 2004, OS build 19041 (May 2020 update). It uses Hyper-V technologies so that needs to be enabled in the BIOS, but WSL2 also runs on Windows Home. It’s significantly faster.

See Windows Subsystem for Linux 2: The Complete Guide – it contains a Docker section.

I had to restore my BIOS settings due to a PC keyboard malfunctioning. After that, Intel virtualization feature was disabled in the BIOS. I’ve turned back on, but when Docker was trying to start I got the “Cannot enable Hyper-V service” error (it was previously working before BIOS reset).

Solution:

  1. turn off Windows Hyper-V feature
  2. turn on Windows Hyper-V feature

Thanks to @mituramikolaj for the solution.

Cheers

Hello,

I have the same issue I try google and so many ways to fix it But I can not to fix it. Anyone can help me. I don’t mind to remote to fix it I need it ASAP.

Thanks

This works for me, thanks

Thanks, switching to Windows containers in the task menu worked for me.

I followed the youtube nothing worked could it be that I need to update BIOS

I tried the remove/re-add from windows features but it did not work. And the machine I was doing was remote so I couldn’t hit the keys to cause the bios settings to appear.

So I finally noticed that if I told the pop Windows error I saw to “continue” rather than “quit”, I could then use the option offered to “switch to wsl2”. (This was an older machine on which I’d had an older Docker Desktop from a couple of years ago.)

just sharing that in case it may help someone else in a similar boat. (The conversion to WSL2 is taking a long time. I hope it will go well and that I won’t lose the images I had. Folks may want to be prepared to recover from that should it happen to you. But as it was, I couldn’t get DD to open otherwise, so it was hosed anyway it seems.)

But I’ve done the conversion to WSL2 on other machines in the past and recall some where I did NOT lose my images. I may not remember to come back here and report, but if anyone sees this and may be interested (before they would do it), if you offer a reply that will get to me and I’d hope to come back with an update.

Same for me as well. Is this issue rsolved? How do you fix it?