Docker Community Forums

Share and learn in the Docker community.

Docker Desktop - Sometimes Not Starting on Reboot - Windows 10

Having an issue starting Docker Desktop on Windows 10 Enterprise LTSC v1809.

What is happening is when the system reboots it attempts to start Docker Desktop and I get the error “Cannot enable Hyper-V service”. What is strange is that if I then close that error window and click on the Docker Desktop icon in the start menu, Docker starts up fine, no errors. Also, if I shut the machine down (instead of doing a reboot) then power the system back on, Docker Desktop starts correctly.

One other thing…if I reboot, sometimes it starts correctly.

I have double checked that Hyper-V is enabled in Windows Features, and I have confirmed that Virtualization is enabled in the BIOS.

I am currently logging into the system as the Admin, so that is not an issue.

I have tried removing the Docker Startup from HKCU\Software\Microsoft\Windows\CurrentVersion\Run in the Registry. Then started the system waited like 5-10 minutes and then run Docker Desktop. I get the same error. But If I then run it again it runs correctly.

Any ideas why it takes trying to start Docker twice before the Hyper-V service works? Or any ideas on why this is happening?

Thanks for any help.