Cannot paste HTTP proxy in Docker Preferences advanced settings

Expected behavior

We now have support for setting HTTP proxy settings from the Docker Preferences menu bar. However, I would expect that I could paste the HTTP, HTTPS, and EXCLUDE in. Having to type it in manually each time I’m in the office is error prone and tedious.

Actual behavior

I have to manually type in the HTTP, HTTPS, and EXCLUDE.


  • docker-for-mac beta 20
  • OSX 10.11.5

Steps to reproduce the behavior

  1. Choose Preferences from the Docker menu bar
  2. Click on the Advanced tab
  3. Attempt to paste in your proxy settings
1 Like