Docker Community Forums

Share and learn in the Docker community.

Cannot start Linux container: No Activity Detected On VM

I have Docker Desktop for Windows :-

Version 2.0.0.3 (31259)
Channel: stable
Build: 8858db3
Engine: 18.09.2

I am running a Windows 10 virtual machine in VMWare Workstation 15.0.4 with 4 cores and 12GB RAM, guest Windows 10 version is 1809 (17763.379).

To create the problem:-
Start Docker Desktop
Switch to Linux Container

After a while the following error is returned:-
No activity detected on VM, aborting
…(rest removed coz it wouldn’t let me post with it in, but it is the same as all the others)

I have seen this issue in many messages and I have tried the recommended solutions (using 1 core not 4 and also resetting to factory defaults), but I still get the same error. I see a lot of the messages just don’t have a solution other than upgrade to the new version, but I have installed the latest version and the problem persists. As with the other posters, Windows containers work fine.

There doesn’t seem to be an explanation either for why this happens, does anyone know what is causing this issue?