Docker Community Forums

Share and learn in the Docker community.

Can't access new GitHub organization for Automated builds


(Miriam Mae Iglesia) #1

Created a new organization on GitHub.
Created a repo inside the new org

In docker hub

  • we’ve already linked our github account into it for Automated builds
  • created a new repo for Automated Builds.
    Issue: we can’t see that new organization

We’ve already tried unlinking and linking back GitHub to DockerHub but we still can’t see the new GitHub org and it’s repos


(Hervé Bredin) #2

I have the exact same problem here…

The GitHub repos of my GitHub organization (pyannote) do not appear in the list (only my personal GitHub repos do) – even though I am a public member of this GitHub organization.

It is strange as, in the past, I did manage to setup automated builds for repos from this GitHub organization – they are still working by the way… (see pyannote/core for instance).


(Jerry Baker) #3

Github recently changed their API. We have an internal ticket open to solve this problem.

Hervé: Could you try unlinking and then relinking with the Public and Private option and see if that takes care of it for you?

Miriam: It looks like you’re already set with the Public/Private option. When you unlinked, did you make sure that all Docker related links were removed from Github? - At github.com > Settings > Applications.

So far, those accounts that have unlinked, then selected Public/Private on the re-link have worked successfully.

Thanks,

Jerry


(Hervé Bredin) #4

Hi Jerry,

Sorry for the delay in answering…

Unlinking and relinking with “Public and Private” option worked for me — though I am not sure I want to give Docker Hub write access to my repos…

Hervé.


(Miriam Mae Iglesia) #6

Hi Jerry,

Sorry for the delay
Unlinking, removing all docker hub access in my github and linking again works for me. Thanks


Organization - Can't set up automated build
(Benzaita) #7

Re-linking did not work for me :frowning:

Any other suggestion?


(Jerry Baker) #8

Morning benzaita,

You may need to revoke the Github access and then request access on your repos when relinking.

Could you try the following:

Note: Public and Private access is required at the moment - There has been a change with the github API. We do have an internal ticket open to fix the limited access.

Also, if you’re using a github organization your profile on your organization’s people page (https://github.com/orgs/your-org/people) has to be set to public.

Thanks,

Jerry


[SOLVED] Relinking GitHub Account broken: Link disappears again
(Benzaita) #9

Jerry, thanks for the prompt response. The procedure you suggested fixed the problem.


(Kevin Pettijohn) #10

Has the limited account access been fixed? I was unsuccessful at adding a Github organization for automated builds using limited access. I would rather not grant read/write access to all organizations if possible.


(Ltangvald) #11

Is there any word on the progress of the internal ticket? Would very much like to have the limited access automated builds back :slight_smile:


(Tvaughan) #12

Any update on getting limited access to work?


(Lorenzo Mangani) #13

For those experiencing this issue with new organizations not being syncronized, you should be able to force this working by doing the following:

  1. create an organization within your hub account with matching name to your new github org
  2. manually assemble your automated build link, ie:

https://hub.docker.com/add/automated-build/github/form/{organization}/{repository_name}/?namespace={repository_name}

  1. make sure the new organization is selected in the dropdown and create

Can't create autobuild for Github organization I am a member of
(Joao C Costa) #14

Docker Hub doesn’t allow the creation of an organization with a dash (hyphen) in the name. Any workaround?
Thx


(Tai Lee) #15

I am still unable to re-link our Docker Hub or Docker Cloud account to a new GitHub organisation and have it show up as an available choice when trying to link a repo created in Docker Cloud with a GitHub repo.

I tried revoking access from GitHub for Docker Hub and Docker Cloud, unlinking from Docker Hub and Docker Cloud, and relinking both Docker Hub and Docker cloud to a public member account of the new GitHub organisation.

I chose the public/private option when linking Docker Hub.

Linking Docker Cloud gave me no choice.

GitHub show that both Docker Hub and Docker Cloud applications are authorised.

Both Docker Hub and Docker Cloud show that they are linked.

And yet, I still can’t see the new GitHub organisation when trying to configure auto-builds for a Docker Cloud repo.


(Pbertera) #16

In case your Github organisation doesn’t appear in Docker you should make sure that the Docker hub is allowed to access the Github organisation.
You can check it on the Github Organisation settings under the Authorised applications


(Krumware) #17

This was incredibly frustrating. In the github organization I ended up having to change github third-party application access to unrestricted, which is less than desireable. Perhaps because my account was the github organization owner, maybe there was a difference in workflow from that of a normal user, and the third-party access request was never triggered back on the organization?

Really hoping someone looks into this one.


(deviantony) #18

This solution, even if not really elegant, works fine !


(Ltangvald) #19

Since it’s been a year, can we assume that the internal ticket to get the public access fixed has been abandoned? The odd thing for us is that the public read-only link we set up before the API change still works, but this is blocking us from adding new products with automated builds (giving Docker Hub unrestricted access to our github repository is not an option).


(Bret Fisher) #20

New GitHub org wouldn’t show up for me in Cloud Auto Builds even after making myself public member of that org and been given owner status. Then I found in GitHub no one had approved in org settings under Third-party application access policy for “Docker Cloud Builder”, and once I approved that, it showed up in Docker Cloud automated builds pulldown within minutes.


(Zhian Kamvar) #21

This solution did not work for me. It got me to the correct page, but when I attempted to create the automated build, it would simply hang (https://github.com/everhartlab/sclerotinia-366-dependencies/issues/2).

I WAS able to create an automated build via cloud, but there are other issues with this:

  1. tags appear not to work
  2. I can’t set any dependent repositories (e.g. rocker/verse)

Note that I was able to get everything working from a fork of this repository in docker hub: https://hub.docker.com/r/zkamvar/sclerotinia-366-dependencies/