Docker Community Forums

Share and learn in the Docker community.

Centos7 docker hello-world fails

#1

Just installed Docker on Centos 7 and I the hello-world test fails. Anyone knows what is going wrong?

[root@test ~]# docker run hello-world
docker: Error response from daemon: OCI runtime create failed: container_linux.go:344: starting container process caused “process_linux.go:293: copying bootstrap data to pipe caused “write init-p: broken pipe””: unknown.
ERRO[0001] error waiting for container: context canceled

[root@test ~]# cat /etc/*release
CentOS Linux release 7.6.1810 (Core)
NAME=“CentOS Linux”
VERSION=“7 (Core)”
ID=“centos”
ID_LIKE=“rhel fedora”
VERSION_ID=“7”
PRETTY_NAME=“CentOS Linux 7 (Core)”
ANSI_COLOR=“0;31”
CPE_NAME=“cpe:/o:centos:centos:7”
HOME_URL=“https://www.centos.org/
BUG_REPORT_URL=“https://bugs.centos.org/

CENTOS_MANTISBT_PROJECT=“CentOS-7”
CENTOS_MANTISBT_PROJECT_VERSION=“7”
REDHAT_SUPPORT_PRODUCT=“centos”
REDHAT_SUPPORT_PRODUCT_VERSION=“7”

CentOS Linux release 7.6.1810 (Core)
CentOS Linux release 7.6.1810 (Core)

[root@test ~]# docker version
Client:
Version: 18.09.2
API version: 1.39
Go version: go1.10.6
Git commit: 6247962
Built: Sun Feb 10 04:13:27 2019
OS/Arch: linux/amd64
Experimental: false

Server: Docker Engine - Community
Engine:
Version: 18.09.2
API version: 1.39 (minimum version 1.12)
Go version: go1.10.6
Git commit: 6247962
Built: Sun Feb 10 03:47:25 2019
OS/Arch: linux/amd64
Experimental: false

2 Likes
#2

close the firewall,retry!
i got the same issue,our webmaster resovle it by this way.

#3

I ran into the exact same error on Ubuntu and it resulted from incompatibility of the new release 18.09.2 with my distribution version. Maybe similar issue?

1 Like
#4

Thank you for the post.

I use CentOS 7.6, but the kernel version was 3.10. So, I’ve seen the same message after I update the docker-ce version Docker version 18.09.2, build 6247962.

To solve this, I updated the kernel version to 4.20, then docker works well.
I’ve followed the process to update the kernel in CentOS in this page.
https://www.tecmint.com/install-upgrade-kernel-version-in-centos-7/

Or you can downgrade the docker version to avoid this issue ASAP.

#5

This is what I ended up doing to get past this issue. Don’t know what the issue was.

#6

Update to 4.20 kernel solved problem for me. Centos 7

(Smxsm) #7

Same here, I had to downgrade Docker to get it working again on Ubuntu 14.04 LTS … :frowning: