Docker Community Forums

Share and learn in the Docker community.

Docker 1.12.0-rc3-beta18 upgrade from Toolbox based Docker installs but does not start


(Davidflam) #1

Expected behavior

As a user I would like to upgrade my toolbox based Docker on Windows to Docker for Windows just by installing the .msi file and following the instructions on Docker website.

Actual behavior

After installation, docker icon is not shown on Windows status bar and I’m not presented with any Toolbox migration assistant window.

Information

install-log
[19:28:11.363][Installer ][Info ] Version: 1.12.0.5226 [19:28:11.364][Installer ][Info ] Starting on: 7/10/2016 7:28:11 PM [19:28:11.365][Installer ][Info ] Resources: C:\Program Files\Docker\Docker\Resources [19:28:11.366][Installer ][Info ] OS: Windows 10 Pro [19:28:11.366][Installer ][Info ] Edition: Professional [19:28:11.367][Installer ][Info ] Id: 1511 [19:28:11.367][Installer ][Info ] Build: 10586 [19:28:11.367][Installer ][Info ] BuildLabName: 10586.420.amd64fre.th2_release_sec.160527-1834 [19:28:11.368][Installer ][Info ] Sha1: ec40b14c72adc0bff3b01fa8886dae7f2eee1541 [19:28:12.003][Installer ][Info ] Killing processes... [19:28:12.008][Installer ][Info ] Migrating Toolbox user... [19:28:12.013][Installer ][Info ] Toolbox user migration completed successfully

log
[19:28:20.858][Program ][Info ] 1.12.0-rc3-beta18 [19:28:20.860][Program ][Info ] Starting on: 7/10/2016 7:28:20 PM [19:28:20.860][Program ][Info ] Resources: C:\Program Files\Docker\Docker\Resources [19:28:20.861][Program ][Info ] OS: Windows 10 Pro [19:28:20.862][Program ][Info ] Edition: Professional [19:28:20.862][Program ][Info ] Id: 1511 [19:28:20.862][Program ][Info ] Build: 10586 [19:28:20.863][Program ][Info ] BuildLabName: 10586.420.amd64fre.th2_release_sec.160527-1834 [19:28:20.864][Program ][Info ] Mixpanel Id: 3F7F56F6-CCB8-44AC-BFDC-8A82E64445E9 [19:28:20.865][Program ][Info ] Sha1: ec40b14c72adc0bff3b01fa8886dae7f2eee1541 [19:28:20.865][Program ][Info ] You can send feedback, including this log file, at https://forums.docker.com/c/docker-for-windows

Steps to reproduce the behavior

  1. Install old Docker based on Toolbox.
  2. Install new Docker for Windows.

(Davidflam) #2

Solved it by removing and reinstalling Hyper-V, deleting all files inside %LOCALAPPDATA%\Docker and removing and reinstalling Docker for Windows 1.12.0-rc3-beta18.