Docker Community Forums

Share and learn in the Docker community.

Docker Upgrade Failed Path Unavailable com.docker.service

The Docker Desktop for Windows community forum is place where users can meet and discuss Docker Desktop for Windows and related technologies.
If you encounter problems with Docker for Windows, we recommend:

  • [reading the documentation]–
  • [searching the GitHub issue tracker]
  • searching this forum
    Issue;
    Latest docker upgrade prior to 3.2.2. failed on Windows 10.
    System is running Windows 10 Version 20H2 (OS Build 19042.867).
    When docker tried to upgrade, it uninstalls and removes the docker VM in HyperV and then
    fails on the reinstall. Tried reinstall with numerous versions but still same issue. I really don’t
    know if my Win 10 upgrade to Version 20H2 killed my Docker upgrade but here is how I resolved the issue.
  1. Do a snapshot so you can restore.
  2. Back up your images. In my case, I have my docker images on a local file so I copied the images to another folder.
  3. Check your WSL set up. I did not have Docker integrated with my WSL but WSL is at version 2.
  4. Verify that the DockerDesktop VM is not in HyperV. If it is there, you have another issue.
  5. Rename the Docker Folder in path like C:-Program Files-Docker-Docker to C:-Program Files-Docker-Docker2. If you may need admin permissions, use the admin permissions to rename.
  6. Reboot Win 10. Remember it is a Windows machine so reboots help.
  7. Run the install program as adm. If everything works, it will still see your registry settings and just do
    an upgrade with a DockerVM created in the HyperV and create C:-Program Files-Docker-Docker file structure.
  8. Test your reinstall. Hopefully, it work fine but your milage may vary.
    Cheers.
    Franz

Finally, if your issue has not been addressed elsewhere, running:

  • :whale: :arrow_right: Settings :arrow_right: Diagnose & Feedback :arrow_right: Open Issues.

This forum is not an official product support or issue reporting channel.