Docker Community Forums

Share and learn in the Docker community.

Updated to 1.12.0-stable and no longer works

docker

(Csharpfritz) #1

I applied the recommended update to 1.12.0-stable according to the popup on my Windows machine and the docker service no longer functions. When I launch Docker for Windows nothing appears in my system tray and no window appears, but Docker for Windows is working in my task manager. I allows this to run for almost an hour and no apparent progress was made.

When I attempt to run “docker version” I receive an error that appears to indicate that the service is not listening properly:

C:\>docker version
Client:
Version: 1.12.0
API version: 1.24
Go version: go1.6.3
Git commit: 8eab29e
Built: Thu Jul 28 21:15:28 2016
OS/Arch: windows/amd64
An error occurred trying to connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/version: open //./pipe/docker_engine: The system cannot find the file specified.

The version number on my Docker for Windows.exe is listed as 1.12.0.5968

I uninstalled and reinstalled docker and now I no longer have a MobyLinux image in Hyper-V nor do I see the docker switch in Hyper-V.

Is there a log file on disk that I can read to get more diagnostic information?


(Michael Friis) #2

When you run the re-install, is that not successful?


(Csharpfritz) #3

Nope… it does not recreate the vm or any other hyper-v resources nor does it open the application. I do see it running in task manager, but it does not actually open


(Csharpfritz) #4

I’ve uninstalled and reinstalled with no change. I see it running in Task Manager, but there is no vm created in Hyper-V nor is there an application in the system tray.

Are there log files somewhere on disk that I can review to learn more about what it is doing?


(Sullivak) #5

I’ve run into the exact same symptoms, though I didn’t happen to notice it coinciding with an update. I haven’t used it for a couple weeks and just found it not working today. Anyway, I tried uninstalling and then installing the beta version (https://download.docker.com/win/beta/InstallDocker.msi) which seems to work.

Update: Not fully working, now I can’t share drives, it won’t accept my password in the Shared Drives settings. I ran into this before and had to change my password to remove special characters. Not sure if it’s related or a separate bug.


(Csharpfritz) #6

I’m wondering if I got caught in some Win10 - Docker for Windows with Windows images trap.


(Csharpfritz) #7

Yahtzee! That worked, I’ve updated to the 1.12.1 beta and it works again.