Docker Community Forums

Share and learn in the Docker community.

Docker and Virtualbox play nicely?


(Profmichaelaars) #1

I have ubuntu 18.04 and virtualbox running a debian image that only works with VMs and not docker because I am told that it needs specific changes to the debian kernel to work. That all seems to work, I was hoping for all docker solution; but whatever…right. :slight_smile:

So I also installed docker-ce and docker-compose to start learning more about them. I ran the hello world and it worked so I enabled docker-ce at boot and revved it up. So then I decided to try a bitnami image for moodlelms to see if something a bit more complicated could be handled. I used docker-compose up -d and it reports all is running at commandline. Bitnami exposes 80:80 and 443:443 for the docker moodle container/images. So I checked that the ufw was indeed off for this and it is. docker reports that mariadb was started and so was moodle. When i use netstat and grep for 80 and 443 nothing… with no other obvious indications.

https://hub.docker.com/r/bitnami/moodle/

So I am beginning to wonder, I know or I think I remember that there has been some talk previously that virtualbox and docker not working well together in the past, but I thought that was on other OSes like windows or osx…but i don’t remember. Is/Are there known issues for running them both in ubuntu 18.04, if so is there a known way around?

Thanks.