is corrupted and unknown date errors on macOS

‹After installing docker and trying to start it, it gives me the message:
“ is corrupted and cannot be opened.”
“This file was downloaded with an unknown date.”
And it is removed from the applications folder.

I already tried everything I found on the internet

  • OS Version/build: 13.2.1 (22D68)
  • App version: Docker 4.17.0

If you can share what you tried, we don’t have to recommend you the whole internet again :slight_smile:

But I searched for the “corrupt” keyword in the “Docker Desktop for Mac” category (where you should have created this topic, but I will move it to there) and found my old answer from last year

where I linked this topic

Since you shared the OS version which is the latest that can’t be the problem, but it is possible that you downloaded the dmg file for the wrong architecture (Intel vs arm) or something happened during downloading. What is the architecture of the CPU in your Mac?


On second thought, “unknown date” seems to be a different problem.

Update 2 (Checking the date of

Mount Docker.dmg

open the mounted Disk under “Locations” called “Docker”

Open the context menu of and select “Show Package Contents”

Open the “Contents” folder

open the “MacOS” folder

open the context menu of “Docker” and select “Get Info”

Check the dates (Modified and Created)

Then you can also check the date on your machine


My result

Sun Mar 26 22:04:54 CEST 2023

Sometimes an incorrect local time can cause problems.

I also moved the topic the the right category and renamed it.