Docker Commands not working

Hello all,

I’m having issues running docker commands with “welcome-to-docker” image provided by default with Docker desktop for Windows 11.

Ultimately, I need to install for following:

git clone

Git command is also not recognized. Any help is greatly appreciated.

I fixed your post to show the url. Please, format your posts according to the following guide: How to format your forum posts
In short: please, use </> button to share codes, terminal outputs, error messages or anything that can contain special characters which would be interpreted by the MarkDown filter. Use the preview feature to make sure your text is formatted as you would expect it and check your post after you have sent it so you can still fix it.

Example code block:

echo "I am a code."
echo "An athletic one, and I wanna run."

Now about the issue: You need to install Git on Windows and configure it properly.

Or enable WSL integration, run a WSL2 distribution in which you install git on Linux. and run the docker commands their. But ti won’t help the GUI to have git s you will still need git for windows for that.

Continuing the discussion from Docker Commands not working:

Hi Akos,

Thanks for your prompt reply. I installed git on my windows 11 machine. From the git bash shell I ran the command:

git clone

I was able to download the F5-journeys git folder. Now my next steps are as follows:

I need to run docker compose, but it’s not working from git bash:

docker compus pull
docker image ls f5devcentral/f5-bigip-journeys-app --digests
docker compus up -d

When I run this command in the git bash shell I get the following output:

myuser@myhostname MINGW64 /c/f5-journeys (main)
$ docker compuse pull
docker: 'compuse' is not a docker command.
See 'docker --help'

The ultimate goal is to run the F5 Journeys docker image. Appreciate your help in advance.

Disregard. Issue resolved! The problem was my WSL Ubuntu distro installed without DNS configuration so name resolution wasn’t working, that plus I had to install my companies web proxy certificate to get github and other basic supporting packages working before moving on the docker commands.

After that I was able to install docker and run the docker compose commands to launch my first container via Ubuntu docker-ce.

Thanks for your reply, it helped set the perspective and cleared the way for me to find the answer! More posts and fun to come. Happy New Year!

I really couldn’t follow your issue. You had a pretty obvious typo in your command. “compus” instead of “compose”, yet the error message mentioned “compuse”. I guess the error message was after you attempted to fix the first command which you quoted.

Then you quoted the wrong command to add that the issue had something to do with DNS in WSL2, which is not related to the command at all.

I tried to leave out certain details for brevity, but the issue from the beggining was i noticed I couldn’t run docker commands. I was also not able to connect to git to download the repos, which is the first step of the readme guide for F5 Journeys tool installation.

When you replied, I noticed I was trying to run the docker commands in the wrong area ( on a container imagine on docker desktop).

I later installed WSL Ubuntu22.04, but initally I couldnt install the packages for docker because ssl was broken because of my companies web proxy cert and my DNS wasnt configured. Kind of multi-faceted problem, but once I fixed the network settings i.e DNS and Certs. I was finally able to download docker-ce, and use git which does an https call for the f5 journeys repo. Basically, in short once me networking was fixed I and the correct packages were downloaded/installed, I was able to run the docker commands and build the image. Which is now working as expected. In the reply above I was trying to describe with commands the issues I faced and resolution incase anyone else has the same issues.

Thank you for the clarification.