Docker Community Forums

Share and learn in the Docker community.

Docker daemon not starting - fresh install of v1.11.2-beta15


(Perhall) #1

Expected behavior

Docker daemon starting

Actual behavior

“Docker daemon is not running”

Information

  • Rather long log file - passed setting up network and there is a MobyLinuxVM running

  • A diagnostic was uploaded with id: 0DCA05CE-AB94-4ACE-8FDB-4C0F65D2BEE1/2016-06-14_22-53-27

  • no DockerDebugInfo.ps1 found using Powershell on Windows

  • Windows 10 Pro 1511 build 10586, swedish locale

  • similar symptoms to Unable to start daemon after fresh install

  • but differerent log, my last log lines ar not looking alarming, only debug level - but there are earlier errors, log snippet:

[22:42:49.351][Cmd ][Info ] Error response from daemon: Bad response from Docker engine
[22:42:49.359][NamedPipeServer][Error ] Unable to execute Start: Docker daemon is not running vid Docker.Backend.DockerDaemonChecker.Check()
vid Docker.Core.pipe.NamedPipeServer.<>c__DisplayClass7_0.b__0(Object[] parameters)
vid Docker.Core.pipe.NamedPipeServer.RunAction(String action, Object[] parameters)
[22:42:49.367][NamedPipeClient][Error ] Unable to send Start: Docker daemon is not running
[22:42:49.378][Notifications ][Error ] Docker daemon is not running
[22:42:49.386][NamedPipeClient][Info ] Sending GetDebugInfo()…
/…/
[22:46:14.884][ProxyProcess ][Debug ] com.docker.slirp.exe: Socket.Datagram 192.36.143.130:123: expiring UDP NAT rule
[22:46:14.889][ProxyProcess ][Debug ] com.docker.slirp.exe: Socket.Datagram.input 192.36.143.130:123: shutting down listening thread

Steps to reproduce the behavior

  1. Clean win10 pro 1511/b10586 machine, install docker as per /windows/getting-started/
  2. Allowing it to enable HyperV and rebooting
  3. New login
  4. got balloon and red docker taskbar icon: Docker daemon is not running

Also tried reboot, Reset to factory defaults and Restart Docker - no change.


(Perhall) #2

Does anyone has an example of a WORKING docker log - to compare where it deviates?

Of course, an annotated version would be wonderful - or lacking that, a pointer to the source code so I can try ad track the progress myself?


(Docker160885) #3

log-2016-06-18_17-43-11.txt (78.5 KB)
My log files for the same error today…