Docker Desktop failed to stop

Hi folks,

I’m currently running Docker Desktop for Windows, version 4.5.1, on Windows 10 Pro, version 21H1, OS build 19043.1503.

After installing Docker Desktop for Windows apparently successfully on Thursday, I was able to use it all day Friday properly on my machine. It was definitely working fine. However, after restarting my machine, I’m consistently getting the message “Docker Desktop failed to stop…” and can’t seem to find a way past this message. This message appears both in the desktop app and in small Docker icon in the “hidden icons” on my machine.

I’ve tried restarting my machine many times. I’ve also tried uninstalling Docker and reinstalling Docker. No matter what I do I keep getting back to the same error “Docker Desktop failed to stop…”.

It was working fine on Friday–I don’t know what changed to cause it to no longer work. Anyone else encounter this error message and know how to get past it?

I have started running into the same problem. Restarting the PC brings Docker up locked in the “Docker failed to stop” state. Only solution I have found is to uninstall and reinstall. Very frustrating.Version 4.7.0
Not to mention the Uninstall takes about 30 minutes now.

Running Windows Pro 21H1. Restarted my machine after closing Docker Desktop, same problem–“Docker Desktop failed to stop.” Only solution to uninstall and rebuild all 3 working containers.