Error "Docker Desktop is shutting down" always after the update

I just updated my Docker Desktop to the latest version and it stopped working at all. I can’t access settings or anything. After rebooting the machine and trying to run the DD app, it always shows

Docker failed to initialize
Docker Desktop is shutting down.

Container mode id WSL2.

How to fix this? I can not just remove it and install it again as the data is important and must not be lost.

1 Like

If I try to reinstall it, it shows:

And I can’t reinstall.

1 Like

I was about to ask the very same question + the very same comment about reinstallation. I need it URGENT because I run like 14 or 15 containers for my regular work and I can’t work until it runs again. Also in WSL2. Also I can’t loose data and I’m affraid an uninstall will probably destroy the data.

Nevertheless I don’t see the “shutting down” box. I just see that no icon in the tray appears + if I watch in the Process Explorer it’s there:

Still in the WSL terminal, not reachable:

2022-11-09_104635_001

The docker command is not accessible in WSL in my case as well.

To reinstall the same version, I had to edit the system registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Docker Desktop

Edit the DisplayVersion and Version to a previous version (I used 4.13.0 and 90345 respectively). This allowed to reinstall the same version keeping data, but the result is the same, it doesn’t work. Going to try an older version.

I found that the docker-desktop wsl distro was not installed.

I managed to bring it back to life saving data. To do that, I had to uninstall DD completely and reinstall from scratch. Here is how I saved my data:

  1. Terminate WSL: wsl --shutdown
  2. Copy the data virtual disk to any backup location of your choice:
    c:\Users\<user name>\AppData\Local\Docker\wsl\data\ext4.vhdx
  3. Uninstall DD completely.
  4. Install the latest version.
  5. Terminate WSL: wsl --shutdown. DD will ask you to restart the engine, ignore it.
  6. Delete the empty docker-desktop-data WSL distribution: wsl unregister docker-desktop-data
  7. Copy your old data disk image back to c:\Users\<user name>\AppData\Local\Docker\wsl\data\ext4.vhdx
  8. Re-register the data distribution: wsl --import-in-place docker-desktop-data c:\Users\<user name>\AppData\Local\Docker\wsl\data\ext4.vhdx.
  9. Restart DD.

This way I’ve got all my containers and data back to life. The only issue I had is with some file bind mounts. Deleting the container and recreating it solved the issue.

Wow, it seems a complete killer because “a regular software update”!!

I’m still broken.

I’ll probably end up following your steps, but I want to try simpler solutions first. I feel this issue is a deal-breaker with doker desktop.

Before going on, I’d love to see “logs” and understand WHY it fails.

Nobody from the docker core team here to help?

For anyone landing here and looking for a solution…

:point_right::point_right::point_right: This one Docker Desktop Failed to Initialize after latest upgrade - #2 by computerbrainhead made it work.

As per the “reasons behind” there’s a cross-post to the originating issue in github issue: docker desktop failed to initialize · Issue #13025 · docker/for-win · GitHub (currently solved on Docker Desktop v4.14.0).

In the meantime, just open the .json file. Edit a line. Save. And it works! :partying_face: