Docker Desktop for Windows Fails to start after Docker update

Docker had been running fine on my laptop until I deleted all containers and Docker asked to upgrade to the latest version I let it upgrade. When the system finished updating, it attempted to start Docker Engine, but it failed to do so. I’ve tried the different recommendations for the old thread for Docker desktop failed to start. None of them worked. I’ve uninstalled and reinstalled Docker. I’ve restarted my machine. I’ve edited settings.json. Nothing works. Help please.

yes, I am also getting the same issue in VM windows server 2022 standard. failed to initialize. i tried both docker and docker desktop it is installed successfully. but not working …!
in vm windows server 2019 it is working fine.
Technical Developer

I have removed the existing docker from my system wuing every command I can think of. However, when in wsl, I can type docker --version and it returns version 24.0.5. What else do I need to do to remove everything related to docker so I can start afresh?