Docker desktop kubernetes stuck on starting

hi All

I am a long time user of docker desktop and kubernetes running on it.
My Mac had an unexpected power down (battery dies at 15% and forgot to plug it in; it needs recalibration) and when rebooting it the clock was reset (CMOS battery issue)
This happened one time before and I was able to bring up docker desktop and k8s started fine after resetting the clock

This time not so fortunate

k8s is stuck on starting. I tried all the usual like restarting docker desktop
I was able to disable k8s after a long time and then tried to restart it and same issue.

I read that deleting the pki file at this location has helped some but when going to that file I did not see the pki file

~/Library/Group Containers/

I do have the original .kube/config file and have not moved it out of the folder. I am not sure if that is something to try.
I think it is the certificate and the time being reset that is causing the issue

Does anyone have any other tips on how to resolve this issue.

warm regards