Docker Community Forums

Share and learn in the Docker community.

Docker Desktop won't stop checking for updates even though I disabled it

Docker Desktop is giving me an annoying popup several times a day, endlessly: “There is an update but you are on OS X 10.13 or an earlier version. Upgrade to the latest version of macOS to install it.”

“Automatically check for updates” is UN-checked in preferences. I have tried restarting/rebooting.

I’m on a 2010 Mac Pro that cannot be upgraded to 10.14 (but otherwise works great) and would prefer not to spend $6,000 for a new one. (And I’ve already tried upgrading the video card for Mojave support, it’s a nightmare.)

Can anyone help me turn off Docker’s automatic update checking?

Thanks :slight_smile:

3 Likes

I too would like to know. I can not upgrade Docker Desktop because I am using a version of Lando that only works with v3.1.0. Yet I always see that little exclamation mark in the corner of the Docker icon!