Docker Desktop won't update on MacOS

  • MacBook Pro 15-inch 2019
  • Docker Desktop 3.6.0
  • MacOS Big Sur

Problem Description

  1. The Docker Desktop icon in the menu bar indicates an update is available.
  2. I click the icon and choose the Update and restart option
  3. Docker icon changes to animated logo implying update is ongoing
  4. Docker icon changes back to the “Update available” status, with the exclamation mark
  5. I presume the update has failed, but I don’t know how to investigate root cause and resolution

What do I do from here?

5 Likes

I am observing the same behavior… Docker Desktop 3.6.0 (67351), 3.6.0 (3.6.0.5487)… says “Download update…” I click the download and then get the “Update and restart” option in the menu… I click it and it appears to go but then after the restart it still indicates “Download update…” and my version of Docker Desktop hasn’t changed. I am on iMac Pro with MacOS 11.5.2… I sent in a support inquiry

I’m having the same problem. I’m stuck on Docker Desktop 3.6.0 (67351) despite numerous attempts to update on my MacBook Pro (15-inch, 2017) running macOS 10.15.7.

Same behavior here. MacBookPro Late 2013, latest OS, Docker 3.6.0

I solved the issue by quitting Docker Desktop and downloading and installing the current version manually.

Same behavior here, Macbook pro 2016 on Mojave.
I’m trying to update manually, fingers crossed :slight_smile:

I just want to share a similar experience but it was not a permanent and serious problem for me. It may give you an idea.

It happaned also on MacOS (Big Sur) some months ago. I got the notification that an update is available. Clicked on the update button but something went wrong and I had two different Docker Desktop icon in the launcher. I thought those were the same, because at the beginning I might have renamed the App before copying it into the Applications folder (I was not sure). So I deleted one icon and tried again seeing that an update is still available. So I clicked the update button again. It was alright then if I remember well.

It was strange but I was a new MacOS user so I thought it was my fault and didn’t try to explain what happened.

1 Like

Macbook Pro 15-inch 2015
Docker Desktop 4.3.1
MacOS Big Sur (11.6)

Same symptoms as @trevorsullivan

  1. Docker Desktop icon in the menu bar indicates update is available
  2. Any attempt to Update fails to resolve the Update Icon, e.g. Restart, Restart, Quit and Restart

Since many of you had similar problem with the Docker Desktop update, I suggest you search for it among the issues on GitHub Issues · docker/for-mac · GitHub
and create a new issue if you can’t find it. Since my problem was long ago and I don’t even know if it was a real issue or I did something wrong, I would not create it. Fortunately I had no problem with the updates recently on my MacOS, but mine is a newer version (MacBook Air 2020, M1 chip). It seems all of you had problem with older versions.

Thank you very much @rimelek, you are very kind to post your follow-up. I did indeed look at the github issues, and it is not clear there is something posted like this. I am continuing to try and debug and will add to the issues list. This may be as you say, only related to older Macbook Pro models.

This issue is ongoing for me on an iMac Pro running Mac OS Monterey v12.1

2 Likes

I’m also having this issue on a Macbook Pro running macOS Monterey.

1 Like

I am also getting the same behaviour. It’s very annoying.

1 Like

This was it for me. Removed the current Docker Desktop icon from the Dock, browsed to Docker Desktop in Applications, and bam.

5 Likes

Similar problem.

Docker Desktop saying I should update from 4.3.1 to 4.4.2.
Takes a long time to download. Then the “update and restart” doesn’t do anything.

This happened several times. Today I noticed Docker isn’t running, and doesn’t show up as an application when pressing Command + Space.

In the applications folder, it’s crossed over. Trying to run it, I get

“You can’t open the application Docker because it may be damaged or incomplete”.

Running Mac OS Monterey 12.2.1 on MacBook Pro (13-inch, M1, 2020)

Edit: I moved the “damaged” application to the trash bin, downloaded again from the Docker website and ran the installer. Now working again and says “Docker Desktop 4.5.0 (74594) is currently the newest version available.”

:question: Did the update download the non-M1 version of the software, breaking it?

I had the same problem. I resolved it by uninstalling Docker Desktop.

1 Like

Mine is stuck at “downloading updates” . Does anyone know the hostname and/or url for docker updates? I want to use dig/curl to make sure my system can access the download site.

For anyone experiencing this, I resolved it be giving Docker Desktop app full disk access and file/folders access on the MAC Security privacy settings. After doing this, it successfully updated and gave a notification that Docker Desktop requires full permissions and you press OK and it updated correctly. Hope this helps.

4 Likes

Docker Desktop’s auto update is unbelievably bad. I was experiencing the hanging update/download problem, and then today the App just became corrupted and I’m having to reinstall. You’d think given the emphasis on pushing out these updates the App would actually be able to install them without self descructing.

Let’s say it straight. Update functionality NEVER WORKED, at least I don’t remember it ever did. It always shows exclamation mark on docker icon, but manual “Download update” fails silently. I always update by re-downloading latest installer.