Docker Community Forums

Share and learn in the Docker community.

Docker failed to initialize

It worked for me as well! Thank you so much for posting the solution!

Your solution worked for me as well. Much appreciated! I opened the settings.json file in Wordpad, deleted the line with the text: " proxyHttpMode: “false” " and saved the file. After that Docker started normally again.

1 Like

I don’t remember when I laughed this hard. Following hint from ccorsano, I, The Smart One, replaced false with “system” in this JSON field.

Guess which error I got next ?

[21:02:51.875][GoBackendProcess ][Info ] msg=“starting backend server”
[21:02:51.876][GoBackendProcess ][Info ] msg=“migrate http proxy mode”
[21:02:51.876][GoBackendProcess ][Fatal ] msg=“error during migrations: proxyHttpMode must be a boolean value”
[21:02:51.881][GoBackendProcess ][Error ] Process died

oh, software is killing me…

I hae a similar problem, frustrated with these errors. One day it works fine and the other day there is some or the other issue. Initially its fun solving these issues but as a beginner its killing the excitement.

I have also tried uninstall and reinstall and the problem persists. Below I have provided the logs I found from the logs document.

[08:30:52.220][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:52.527][IPCClient         ][Info   ] (5c1e7562) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:52.527][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:52.829][IPCClient         ][Info   ] (ef48f141) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:52.829][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:53.134][IPCClient         ][Info   ] (65b865ae) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:53.134][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:53.453][IPCClient         ][Info   ] (407e7f0b) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:53.453][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:53.765][IPCClient         ][Info   ] (5eb08221) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:53.765][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:54.067][IPCClient         ][Info   ] (aa9cb83b) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:54.067][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:54.380][IPCClient         ][Info   ] (eaec7f63) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:54.380][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:54.693][IPCClient         ][Info   ] (8f125368) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:54.693][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:55.008][IPCClient         ][Info   ] (b2e7f848) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:55.008][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:55.321][IPCClient         ][Info   ] (92c48810) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:55.321][GoBackendClient   ][Warning] HttpOS Client: connection timed out.

Thank you so much. This absolutely solved the problem.
I had uninstalled and reinstalled with the latest version to no avail.
This solution works!

This worked like a charm

Thank you it worked for me.

This worked for me as well. Not sure if it is necessary to uninstall/reinstall Docker for Windows after deleting these three folders, but I did and it worked.

Thanks! This worked for me!

yeah! It worked thank you!!!

Saved me a load of pain… thanks

It’s worked for me, Thanks!

Thanks this is still working…
worked for -
Docker failed to initialize
Docker desktop is shutting down.

There is a new upgrade of Docker for Windows. I’m a little hesitant to install it. Has anyone installed the latest update for Windows 10 and is it working?

it Works for me !!!

Thanks. I’ll install it today.

This worked for me after the update to 3.6.0. It is important that the setting be deleted. Changing it to “system” resulted in the following error in the log:

msg=“error during migrations: proxyHttpMode must be a boolean value”

It worked, thanks for posting this!

If you get “proxyHttpMode must be a boolean value” or something similar then no need to reinstall or nuke settings. Open the AppData\Roaming\Docker\settings.json file, look for proxyHttpMode. If it has a true or false value then either remove it or use the value "system" (the quotes are part of what you need to use since it’s a string value instead of the older boolean).

Kind of worked for me… I got the following error after docker started