Docker Community Forums

Share and learn in the Docker community.

Docker for windows won't launch

Has anyone had any problems with Launching Docker for Windows lately, haven’t started docker for a couple of days but now it wont launch. had a windows update a couple of days ago could that be the culprit?

if anyone have had similar problems please let me know otherwise i’ll re-install docker

thanks

Fred

3 Likes

I was having a similar problem a few days ago. I can’t garuntee this will work but it worked for me. I first of all tried re-installing but it made no difference the solution I found was to delete the private-invites-signature.txt file that is located at “C:\Users{Username}\AppData\Roaming\Docker” and then when you either re-install or start up docker for windows (cant remember which) it will ask you for your intivation code again put it in and then it should start up just fine after that.

tried to remove the private-invites-signature.txt and run again and it did not work so I uninstalled docker and installed again still wonth launch the docker application. I can however see that the DockerForWindows service is running but it wont allow me to connect to docker. and no icon in the taskbar. still think this must have been something in last windows update that caused this. any ideas?

According the guide in Getting Started, ran the hello-world right after the installation, and got the error messages.

1 Like

It can work fine now after restart the Docker for Windows Service.
Thanks!

1 Like

yep getting the same error, tried restarting the service but still getting the same message :cry:
/F

Same for me for the new 1.12-rc2.
Checked the loga and hyper v.
manually deleted the remaining docker NAT and restarted docker. Now working again!

  1. stopped Docker for windows service
  2. run installer and selected remove
  3. removed Docker in AppData/Roaming
  4. removed docker from ProgramFiles
  5. restart machine
  6. installed again, installation works fine and service start however no Virtual machine is configured in Hyper-v

anyone with ideas?

2 Likes

@ftnilsson I’d try:

  • Make sure there’s definitely no VM in Hyper-V
  • If there is, remove it
  • Do a “Repair” on “Docker” from “Programs and Features”, this usually recreates the VM if it doesn’t exist

I’ve had a few issues lately on the latest update (1.12.0-rc2-beta16 build 4760) where the VM became unresponsive in Hyper-V (wouldn’t shut down) then on reboot the VM would start but the Docker service couldn’t set up networking to it. Don’t know if it’s version related, or my setup. Removing the VM and repairing seemed to fix, tho obviously not ideal as you have to redo all your containers.

I hope anyone can shed me a light on this. I have benen trying to run the command line below to join a Windows Server 2016 to a swarm of Linux Servers:

“C:\Program Files\Docker\dockerd.exe” --run-service -H npipe:// -H 0.0.0.0:2376 --tlsverify --tlscacert=C:\ProgramData\docker\daemoncerts\ca.pem --tlscert=C:\ProgramData\docker\daemoncerts\cert.pem --tlskey=C:\ProgramData\docker\daemoncerts\key.pem

But everytime i do so, i just simply get the error below:

Testing for required windows updates = [System.Version]::Parse 10.0.14393.1066 = [System.Version]::Parse 10.0.14393.1066 if False
Write-Host “System is missing a required update. Please check windows updates or apply this KB4015217: http://www.catalog.update.microsoft.com/Search.aspx?q=KB4015217 before adding this node to your UCP cluster” -ForegroundColor yellow Write-Host Setting up Docker daemon to listen on port 2376 with TLS

I have attempted to install KB4015217 on Windows 2016 and Windows 10, but the servers don’t see the update as required. Any help would be much appreciated.

It looks like the OP’s problem is different from mine but I’m going to post my results here because the title will lead a lot of folks to this thread.

This is for Version 18.03.0-ce-rc1-win54 (16164)

This was posted elsewhere and I don’t remember by whom so I can’t credit it. I didn’t try this solution when I first read it because it just seemed so odd but when I finally did try it, it solved the problem for me.

The issue for me, and for others, was installing Docker for Windows with any network or Internet connection. I think the install triggers Docker to connect online for something and that connection fails and things break. The install completes but Docker won’t start or at least won’t go far enough in starting for you to get any indication. Nothing I could think of, reinstalling, repair installing, or anything else would work.

Finally, based on what I’d read in at least one post here or elsewhere, I disconnected from all networks and then ran the installer. I started Docker the first time while still not connected to any network and the sign-in dialog opened. I connected my network, signed in, and then Docker completed loading and from then on it’s worked just fine.

I know it sounds strange and unlikely, but it’s worked for me and at least one other.

I don’t know if it’s even supposed to ‘launch’. I see screenshots of a GUI posted here and there, but mine said it’s running and to open a terminal and start ‘hacking’ away. It will let me log in, whatever that’s supposed to do, but that is the only thing like a GUI I’ve got anywhere. I don’t really know if it’s supposed to have a GUI. Documentation is typical, everything starts with the same four pages about containers in general and how great it is, then skips saying anything about what to actually expect or how to operate it if you aren’t already familiar with it.

A bit late,but having the same problem. The ‘GUI’ is in the tray, click the ^ up arrow, find the docker icon, right-click, click settings. Otherwise you are right, there is no GUI to operate Docker generally, it is all CLI based.

6 Likes

I’ve constantly got this over the years, the simplest solution I’ve found is to restart the “Windows Management Instrumentation” service. This causes hyper-v to restart, once that’s all done just try to start Docker Desktop again

1 Like
  1. Well, in my own case after installing docker for desktop on my windows 10 pro computer, I discovered it was running in the windows task-bar at the bottom right corner of the screen (In the event that you have other background services running, then it will be minimized into a menu group, showing a caret (^) icon pointing upwards). 
    
  2. In order to use a GUI with docker desktop for windows to manage containers, I had to download a GUI called "Kitematic" Which does not come bundled with docker desktop for windows.
4 Likes

Ok now I signed up, just to post my solution for the same problem. At first I could not start Docker Desktop anymore. After uninstalling, I could not even start the installer anymore :scream_cat:

@rjohnsoninterica gave the hint for me. But for me restarting the Windows Management Instrumentation service did not work. Instead, I restarted all running Hyper-V services directly. After that, I could install it again successfully.

I don’t know if i am super stupid or answers are too advance, but I don’t know how to do any of the mention. other people seems to know things like “restart Hyper-V services directly” “just restart window management instrumentation service” what is hyper-v services ? how can I even get it? and how do I run “window management instrumentation service” in my computer. super lost and really not beginner friendly at all.

2 Likes

In my case I had to start the ‘Server’ and ‘Docker Desktop Service’ services manually.

Thanks. The dashboard is also available there

For me ending processes docker.exe and docker desktop, which were active, in Task Manager and some time awaiting after doubleclicking worked