Docker Desktop Failed to Initialize after latest upgrade

I installed the latest update this morning (4.13.0). When I tried to launch afterwards it presented an error dialog that says “Docker failed to initialize Docker Desktop is shutting down.”

Everything has been fine for me with Docker Desktop for months.

I noticed that I don’t have the docker-desktop wsl2 that is mentioned here [1],

PS C:\Windows\System32> wsl --status
Default Distribution: docker-desktop-data
Default Version: 2

Windows Subsystem for Linux was last updated on 3/28/2022
WSL automatic updates are on.

Kernel version:
PS C:\Windows\System32> wsl -l -v
  NAME                   STATE           VERSION
* docker-desktop-data    Stopped         2
  Debian                 Running         2

I can’t tell by looking at the install.log if everything is as expected or that missing service it tries to kill is actually a problem?

Version: 4.2.0 (70708)
Sha1: eb84a759291f14fe31a97526cb8b137e6e541763
Started on: 2022/10/28 08:34:58.342
Resources: C:\Program Files\Docker\Docker\resources
OS: Windows 10 Pro
Edition: Professional
Id: 2009
Build: 19043
BuildLabName: 19041.1.amd64fre.vb_release.191206-1406
File: C:\Users\Scott\AppData\Local\Docker\install-log.txt
CommandLine: "C:\Program Files\Docker\Docker\InstallerCli.exe" -k -p
You can send feedback, including this log file, at
[08:34:58.651][Installer         ][Info   ] Killing processes...
[08:34:58.666][Installer         ][Info   ] Killing existing com.docker.service process with PID 6304
[08:34:59.402][Cmd               ][Info   ] time="2022-10-28T08:34:59.401584200-07:00" level=fatal msg="The specified service does not exist as an installed service."
[08:34:59.410][Installer         ][Info   ] Preparing upgrade...
[08:34:59.462][HyperV            ][Info   ] Destroy
[08:34:59.686][HyperV            ][Warning] Hyper-V is not installed on the machine
[08:34:59.689][LinuxWSL2Engine   ][Info   ] Destroying distro
[08:35:00.109][LinuxWSL2Engine   ][Info   ] Debian: found credsStore with desktop.exe, rewriting
[08:35:00.188][Installer         ][Info   ] Prepare upgrade completed successfully
[08:35:00.188][Installer         ][Info   ] Fixing permissions...
[08:35:00.189][Installer         ][Info   ] Deleting directory C:\Program Files\Docker\cli-plugins
[08:35:00.191][Installer         ][Info   ] removing permission inheritance from C:\ProgramData\DockerDesktop
[08:35:00.192][Installer         ][Info   ] removing ACLs except for SYSTEM and Administrators from C:\ProgramData\DockerDesktop
[08:35:00.192][Installer         ][Info   ] granting ReadAndExecute to everyone for C:\ProgramData\DockerDesktop
[08:35:00.193][Installer         ][Info   ] removing permission inheritance from C:\Program Files\Docker\cli-plugins
[08:35:00.193][Installer         ][Info   ] removing ACLs except for SYSTEM and Administrators from C:\Program Files\Docker\cli-plugins
[08:35:00.194][Installer         ][Info   ] granting ReadAndExecute to everyone for C:\Program Files\Docker\cli-plugins
[08:35:00.195][Installer         ][Info   ] removing permission inheritance from C:\ProgramData\Docker
[08:35:00.195][Installer         ][Info   ] removing ACLs except for SYSTEM and Administrators from C:\ProgramData\Docker
[08:35:00.195][Installer         ][Info   ] granting ReadWriteDelete to authenticated users for C:\ProgramData\Docker\config
[08:35:00.195][Installer         ][Info   ] Permissions should be fixed.

Also looking at log.txt this section at the end seems possibly related but I wasn’t sure?

[2022-10-28T20:09:26.329762600Z][GoBackendProcess  ][Info   ] [main.main()
[2022-10-28T20:09:26.329762600Z][GoBackendProcess  ][Info   ] [	common/cmd/com.docker.backend/main.go:109 +0x130
[2022-10-28T20:09:26.332893600Z][GoBackendProcess  ][Info   ] notifying bugsnag: setting overrides for proxies: computing HTTPIP of prefix of 28 does not accommodate a host numbered 128
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] bugsnag.Notify: bugsnag/payload.deliver: Post "": proxyconnect tcp: open \\.\pipe\dockerHTTPProxy: The system cannot find the file specified.
[2022-10-28T20:09:26.333891600Z][com.docker.backend.exe][W] failed to send bugsnag report: bugsnag/payload.deliver: Post "": proxyconnect tcp: open \\.\pipe\dockerHTTPProxy: The system cannot find the file specified.
[2022-10-28T20:09:26.333891600Z][com.docker.backend.exe][F] setting overrides for proxies: computing HTTPIP of prefix of 28 does not accommodate a host numbered 128
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [main.reportIfFatal({0x1ed18a0?, 0xc00041c1c8?}, {0x0?, 0x1?, 0x1?})
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [	common/cmd/com.docker.backend/main.go:830 +0x98
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [main.makeConfig(0xc000268480, 0x0)
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [	common/cmd/com.docker.backend/main.go:589 +0xa19
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [main.newBackendServices(0x1adcde0?)
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [	common/cmd/com.docker.backend/main.go:243 +0xb4b
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [common/pkg/appfw.makeNodeDscr[...].func1()
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [	common/pkg/appfw/helpers.go:124 +0x29
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [common/pkg/appfw.(*Node).startSubNodes.func2(0x4?, {{0x1c1d283?, 0x37?}, 0xc0008dfc90?, 0xc00041c6d8?}, 0xc0003b0840, 0xc000218378, 0xc00045ac60?, 0xc000c33c70, 0xc00029dc50)
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [	common/pkg/appfw/appfw.go:792 +0x1c5
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [common/pkg/appfw.(*Node).startSubNodes(0xc0003b0840, {0xc000c33f30, 0x1, 0x1a357a0?})
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [	common/pkg/appfw/appfw.go:813 +0x69b
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [common/pkg/appfw.(*Node).StartSubNodes(0xc0003b0840, {0xc0008dff30?, 0x0?, 0x1d10a38?})
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [	common/pkg/appfw/appfw.go:756 +0x27
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [common/pkg/appfw.StartSubNodes({0xc0008dff30, 0x1, 0x1})
[2022-10-28T20:09:26.333891600Z][GoBackendProcess  ][Info   ] [	common/pkg/appfw/helpers.go:18 +0x3f
[2022-10-28T20:09:26.334890500Z][GoBackendProcess  ][Info   ] [main.main()
[2022-10-28T20:09:26.334890500Z][GoBackendProcess  ][Info   ] [	common/cmd/com.docker.backend/main.go:109 +0x130
[2022-10-28T20:09:26.356780600Z][GoBackendProcess  ][Info   ] C:\Program Files\Docker\Docker\resources\com.docker.backend.exe -addr unix:\\.\pipe\dockerBackendApiServer -native-api exited with code 1
[2022-10-28T20:09:29.160122400Z][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[2022-10-28T20:09:29.160122400Z][SettingsLoader    ][Warning] Failed to fetch settings from backend, retrying in 1 sec
[2022-10-28T20:09:29.160122400Z][IPCClient         ][Info   ] (dea5ed3e) 1c1c9b88-GoBackendClient-CSharp C->S BackendAPI GET /ping
[2022-10-28T20:09:30.170080900Z][SettingsLoader    ][Error  ] Failed to initialize settings loader: unable to ping backend API: The operation has timed out.

Can anyone recommend how I can get Docker Desktop to start again? Should I just uninstall and re-install?

[1] Docker Desktop WSL 2 backend | Docker Documentation


I found this issue [1].

I changed this in c:\Users\Scott\AppData\Roaming\Docker\settings.json,
"vpnkitCIDR": "", to "vpnkitCIDR": "", and Docker Desktop started up.

Sorry for the noise.

[1] issue: docker desktop failed to initialize · Issue #13025 · docker/for-win · GitHub


everything is ok for me with this fix, thanks :wink:


Exactly the same problem as described and this fixed it for me.
I have never edited that file by hand so something must have changed with the update.

Same issue, same fix but happened when I upgraded to 4.13.1 on two separate machines both upgraded from 4.12.0 → 4.13.1

Both machines really couldn’t be more different:
Machine A - Intel processor, no discrete GPU, running windows 10, joined to a domain, common enterprise security suites, vpn client, etc.
Machine B - AMD processor, NVidia discrete GPU, running windows 11, not joined to any domain, no security software outside what windows 11 provides.

I also did not modify anything in the settings.json file manually on either machine until today.

Same issue after upgrading to 4.13.1, and the fix mentioned /28 by /24 fixed the issue to me


Perfect, this solved it for me, thanks!!

This solved it for me also, thanks!

Same issue after upgrading to 4.13.1. The fix from /28 to /24 was effective to me as well. Thank you very much for taking the time to post the solution.

another successful fix after upgrade to 4.13.1…many thanks

You saved my day. Thanks

Your fix worked for me! Thanks a lot.

You saved my day as well after upgrading to 4.13.1.

Sorry to add another to the chorus, but on a 3 day weekend after a hellish week, and this issue reoccurring after a full restore and subsequent re-upgrade… you made my week, thanks for sharing!

Saved my bacon. Thank you so much for sharing this. I was losing my mind.

@computerbrainhead Scott, you made my day! Thanks! :partying_face: Or my week! as @bowroat said :star_struck: - Another +1 here.

I just updated to 4.14 and I’m still getting the Docker failed to initialize Docker Desktop is shutting down. I’ve uninstalled and reinstalled. I’m a novice when it comes to programming and troubleshooting so I have no clue what to do or try.

Have you tried @computerbrainhead’s solution? It looks like it helped many people.

Yes, with 4.14.0 its already 24 and not 28:
“vpnkitCIDR”: “”

I’m not sure what version I was running and just did an update to 4.14 and now it gives me the failed to initialize.

I am in the same loophole as you @svargo22, I upgraded to 4.14 → “Docker failed to initialize”. The vpnkitCIDR is already set to

“vpnkitCIDR”: “”