Docker Community Forums

Share and learn in the Docker community.

Docker for Windows beta-Kitematic doesn't work


(Docker160885) #1

Expected behavior

Should be able to start VM like it used to with Toolbox

Actual behavior

Kitematic is unable to start. Keeps retrying and asking to use virtualbox.

Information

Because the VM on Windows 10 Pro is Hyper-V now. Shows a message that it can only work with Toolbox Virtualbox. Since I didn’t have toolbox installed earlier on that machine, It doesn’t work. On my Mac OS X El Capitan I had toolbox installed earlier so Kitematic works there. But I think the Virtualbox version of VM overrides the xhyve VM there.

Steps to reproduce the behavior


(Afischer211) #2

Which version are you using? With Kitematic 0.10.3 and up I have no basic problems with DfW, only small glitches with not shown folder-mappings, if the host.directory is not drive c (but the mappings are working itself).


(Docker160885) #3

Checked my kitematic version file which said v0.35.4. So I downloaded a kitematic 0.10.3 zip from http://www.oschina.net/news/73300/kitematic-v-0-10-3 but that didn’t work either (same message “Retry setup” or “Use Virtualbox”). More so, checked the version file there as well and it said v0.35.4. Strange but anyway. I had the docker toolbox installer. If I install kitematic using that I cannot uncheck installation of Docker Client for Windows and Docker Machine for Windows. Debating whether to do that as it makes me think I’ll then have two different versions of docker on my machine: Docker Toolbox and DfW. I really want kitematic to work with DfW and HyperV.


(Afischer211) #4

You can download the official version from Github under https://github.com/docker/kitematic/releases.
I use the version 0.10.5 (latest).


(Docker160885) #5

Yes. Tried it with 0.10.5. Still doesn’t work. I run DfW first and then start Kitematic. Kitematic still can’t connect. Just to clarify is this the 1st time u’re using docker on that Windows machine or did you have Docker Toolbox installed earlier ?


(Afischer211) #6

I had installed docker-toolbox before, but with switch to DfW I uninstalled the docker-toolbox and also virtual box. So I have only installed D4W now.
Also with docker-toolbox Kitematic runs good before.


(Docker160885) #7

where are you keeping your kitematic folder ?


(Afischer211) #8

I have unpacked the zip-archiv in a folder under C:\Program Files. I think, also other folders should work.


(Docker160885) #9

Finally managed to get Kitematic working with HyperV. So turns out kitematic wasn’t able to find my local MobyLinux DfW server and kept looking up docker hub servers (142.54.173.92:2375) for my DfW host. I had to do one thing to fix this. This link helped me out: https://stefanscherer.github.io/first-impressions-of-windows-2016-tp5/ . Added the line “127.0.0.1 docker.local” to C:\Windows\system32\drivers\etc\hosts, restarted DfW and everything works fine from then on. Need Kitematic 0.10.3 or later (for DfW support) and might help if Kitematic is ‘run as admin’ for the first time.


(Afischer211) #10

But normally the command “ping docker.local” resolves to 10.0.75.2 (the ip of the mobylinux vm)…
If I add the new alias-line in etc/hosts, the alias docker.local is not working anymore in browsers or so…
Is this alias “docker.local” only needed for Kitematic?


(Docker160885) #11

hey, yes this starts kitematic for me. the new way i.e., without needing a separate kitematic VM (earlier you’d need default or dev VM created from boot2docker.iso in docker toolbox environment). adding that alias connects kitematic directly to my docker host. if I ping docker.local without the line in hosts docker.local gets resolved to 142.54.173.92 (today) and gets valid responses. I don’t know what that ip address is about. google search says its an IP address in Missouri, US. and kitematic doesn’t work in this scenario. after adding that line to hosts, kitematic works, ping docker.local still works but just resolves to my localhost and gets valid responses. if i set docker.local in that hosts file to 10.0.75.2 it works as well but i guess 127.0.0.1 is more generalized way of doing that (if in future docker changes that ip). when you say the alias docker.local isn’t working on browsers, you’ve started some web server in docker first, right ?