Docker Community Forums

Share and learn in the Docker community.

Docker invalid message - Error response from daemon: invalid mode

I am using windows 10 home, so unable to install docker desktop. I need to install docker toolbox instead since windows 10 home does not have hyper v I need to install influxdb and follow the tute below:

https://www.open-plant.com/knowledge-base/how-to-install-influxdb-docker-for-windows-10/

When I executed the following:

>docker run -p 8086:8086 -v C:/ProgramData/InfluxDB:/var/lib/influxdb influxdb -config /var/lib/influxdb/influxdb.conf

It returns an error message below

docker : C:\Program Files\Docker Toolbox\docker.exe: Error response from daemon: invalid mode: /var/lib/influxdb. At line:1 char:1 + docker run -p 8086:8086 -v C:/ProgramData/InfluxDB:/var/lib/influxdb … + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (C:\Program File…r/lib/influxdb.:String) , RemoteException + FullyQualifiedErrorId : NativeCommandError

See ‘C:\Program Files\Docker Toolbox\docker.exe run --help’.

I tried the solution in this url: Docker Toolbox: Error response from daemon: invalid mode: /root/docker

by adding “//” instead of “/” but still does not work and have the same error message. Can someone please assist? Thanks.