Docker-machine keeps reporting invalid TLS certificates


it seems out of nowhere, I suddenly keep receiving the below failure over invalid TLS certificates. Even after regenerating it, I get the same failure message the next time I run eval $(docker-machine env dm_name):

Error checking TLS connection: Error checking and/or regenerating the certs: There was an error validating certificates for host “”: x509: certificate has expired or is not yet valid

I then stopped the docker daemon, and did this below as one suggested.

                 rm -rf /var/lib/docker/network

But it’s still the same.

I then upgrade my docker-machine from 9 to the newest 16, and restarted docker daemon. But to no avail. Everything’s still the same.

The only docker-machine that is still working is my private insecure registry.

For every docker-machine that I need to run 'eval $(dm env swarmgr), it fails, despite I regenerated the certs.

What else can I try to fix this issue? Any insight is greatly appreciated…