Docker Community Forums

Share and learn in the Docker community.

Docker gone after failed upgrade attempt

Hi,

I just tried to upgrade Docker by clicking the pop-up that pops up regularly, saying it’s time to upgrade. It seemed to work well until the end when I got some error messages which I unfortunately didn’t screenshot. I closed them and after that the whole installation was gone. No files anywhere, I cannot run docker on cmd. The only thing left is the empty Docker folder in Program Files.

This seems like a pretty nasty bug? Is there any way to recover what I had or do I have to start from scratch?

Chances are > 0. First I would try to re-install the previous version. If this doesn’t work, make sure your are on the latest Widows release (don’t trust the automatic updates), try again with the latest stable version. If it still doesn’t work use the edge version.
For the future: Always expect bad things to happen when you make an update. So always create a backup of your volumes, maybe of your images too before you do that.

1 Like

Thanks! I just reinstalled it and it actually managed to get back to normal. I have no idea where those files were stored but it just automatically started my old container again.

Where the files are stored depends on how you use Desktop. If you use it with Hyper-V they are located in a virtual hard disk, if with WSL2 they are stored in the distribution ‘docker-desktop-data’. With backup I don’t mean to copy these files but to export the images (see here) and create tar files of the volumes as described here.