Docker Community Forums

Share and learn in the Docker community.

Docker Windows Client doesn't start and there is no icon in system tray

Recently, I installed Docker for Windows and pulled the Get-starting container for WSL and it worked fine. However, after I restarted my computer, the client doesn’t start automatically, when I once start it manually nothing happened and after starting it again, it shows me docker failed to initialize the operation has timed out.


I don’t remember doing something that makes a problem. Then I checked the version of Docker in PowerShell ad administrator and the result is:

PS C:\Windows\system32> docker version
error during connect: In the default daemon configuration on Windows, 
the docker client must be run with elevated privileges to connect.: Get 
"http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/version": open 
//./pipe/docker_engine: The system cannot find the file specified.
Client:
Cloud integration: 1.0.17
Version:           20.10.7
API version:       1.41
Go version:        go1.16.4
Git commit:        f0df350
Built:             Wed Jun  2 12:00:56 2021
OS/Arch:           windows/amd64
Context:           default
Experimental:      true

I also tried (Docker cannot start on Windows - Stack Overflow) and it doesn’t work. Any help would be appreciated.