Docker Community Forums

Share and learn in the Docker community.

Excluding docker images from time machine


(Erik-Berndt Scheper) #1

Information

When using docker toolbox, it is straightforward and easy to exclude the vm from any time machine backups. I would like to achieve the same result using the new docker for mac, but I cannot find the relevant directories in the current documentation. Any help here would be appreciated.


(Bryce Ryan) #2

Hi,

Please try this:

Whale -> Preferences -> General
Tick the box next to "Exclude VM from Time Machine backups
Close the Preferences dialog

Hope this helps,

Bryce


(Erik-Berndt Scheper) #3

Is this actually working for Version 1.12.0-rc2-beta16 (build: 9493), which is no longer using virtualbox? I thought this was a remnant of the ‘old’ docker toolbox gui.


(KnutsenM) #4

I think this is still working - I removed old backups, then toggled on the preference, rebooted, and ran a new backup. It did not save the large “com.docker.driver.amd64-linux” folder in ~/Library/Containers/com.docker.docker/Data, even though there is no exclusion mentioned in Time Machine’s preferences.

I’m running version 1.12.0-rc4-beta20 (build: 10404)


(KnutsenM) #5

However, it appears that the BackBlaze service does not exclude .qcow2 files; or if they once did, they no longer do. I’ve written to suggest they add that as a default exclusion.


(Justin Nauman) #6

Can confirm this is still functional. You can look at the files that TimeMachine will be ignoring by using sudo mdfind "com_apple_backup_excludeItem = 'com.apple.backupd'", which I found via http://apple.stackexchange.com/a/25833/35333.

Comparing a “before” and “after” on my machine, I found that /Users/justinn/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux was introduced when selecting the checkbox.