Installing Docker on Windows 10 Home

The installation worked for me following @mapk and @hessi9 's instructions. Also, aruku64 I had the same issue, restarting after editing the registry reverts the changes. So you were correct, you need to edit the registry and then start the installation.

My steps:

  1. To install HyperV on Windows Home I used @hessi9 bat commands
  2. To install Docker on Windows Home without having to install a 3rd party product I used @mapk tip (change registry instead of editing installer).

Additional Info: It was necessary only to change the following registry key:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\EditionID which in my case were CoreSingleVersion.

Cheers and thank you all.

Thank you so much @hessi9 and @mapk! I have consolidated this thread into a Gist


i don’t know if this is still an issue for you, but i just had the same problem.

using windows containers (@installation) instead of linux solved the problem for me

Hey guys,
I am having an issue with installing the Hyper-V components… the script is looping forever (it seems finished 100% but I need to close the powershell window to stop it).
I did try to install Docker with checking / unchecking boxes, got to install it, but there was an error at launch again.
Any ideas,


We have now released a version of Docker Desktop Edge that allows users of Windows Insider Preview (Win Home 19018 or higher) to use Docker Desktop with WSL 2.
If you are trying this out and have issues feel free to drop issues on the for-win Github Repo!


1 Like

I had followed @hessi9’s method to install docker. But now that it supports Windows 10 Home, without hyper v, I have been unable to deactivate hyper v, making virtualbox and intel haxm unusable.
I tried Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All and it returns a success but there are hyperv network adapters and hyperv services running in task manager. When I open “Turn features on/off”, hyperv is unticked.

Any idea how to completely uninstall hyperv from windows 10 home?

Thanks a lot @hessi9 and @mapk . It works like a charm, follow the steps and working fine.

Do you try this?

thx! it work for me - docker 2.2.3

showing error please help to remove ?

1 Like

From May 2020 Docker is available on Win 10 Home. For that you will have to update for the last windows (Windows 10 Home. version 2004) and the new version of Linux Subsystem (WSL2). You can simply do it from your Control Panel.
After that, you can simply install Docker as described here:

No way, checked all requirements, updated everything - no way I can run this sh…

Plenty of us have Docker working on Win 10 Home. Please confirm that you have updated to 2004 or higher and already have WSL2 working. We really can’t help you without level information and error messages.

Oh, I sorry guys, I forgot to check if virtualisation enabled in BIOS )))

I followed the instructions and I successfully installed the latest docker for Windows. Now I get error during connect. As far as I can see I enabled the Virtualization from BIOS (I can see it under Task Manager/Performance) and SystemInfo reports “Hyper-V Requirements: A hypervisor has been detected. Features required for Hyper-V will not be displayed.” which means that Hyper-V is running.

What is the root of the problem and how to solve it?

PS D:\download> docker version                                                                                                                                       Client: Docker Engine - Community
 Azure integration  0.1.15
 Version:           19.03.12
 API version:       1.40
 Go version:        go1.13.10
 Git commit:        48a66213fe
 Built:             Mon Jun 22 15:43:18 2020
 OS/Arch:           windows/amd64
 Experimental:      false
error during connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.40/version: open //./pipe/docker_engine: The system cannot find the file specified. In the default daemon configuration on Windows, the docker client must be run elevated to connect. This error may also indicate that the docker daemon is not running.

I’m seein galmost exactly the same error, any updates yet?
Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.

Try the new cross-platform PowerShell

PS C:\WINDOWS\system32> docker version
error during connect: In the default daemon configuration on Windows, the docker client must be run with elevated privileges to connect.: Get “http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/version”: open //./pipe/docker_engine: The system cannot find the file specified.
Cloud integration: 1.0.14
Version: 20.10.6
API version: 1.41
Go version: go1.16.3
Git commit: 370c289
Built: Fri Apr 9 22:49:36 2021
OS/Arch: windows/amd64
Context: default
Experimental: true
PS C:\WINDOWS\system32>

if you are under Windows 10 Home forget it, I upgraded to PRO, uninstalled docker, installed it again and it worked. Only this way, I solved any problems with docker.

Really awesome. Its working on Windows 10 home edition now.

Hey, After running this batch file, my window is perfoming very wierdly, whenever i am starting the window black screen is coming again and again. then screen star to fliker. To to revert ? I want to go to the previous state of my window. i want uninstall this program completely.