Installing Docker on Windows 10 Home

I am trying to learn Dockers on my HP laptop that comes with Wi 10 Home OOTB. by installing it however disheartened by the opening lines at Virtualisation should be enabled. For my machine on Task Manager it shows Virtualisation is Disabled. However, Hyper-V Support is indicated as “Yes”. Is there any hope for me to install it without upgrading my Windows to Pro (which I won’t). Thanks for helping me learn Docker.

Hi dchucks,

Windows 10 Home edition does not support Hyper-V see here:

This does not mean you can’t use Docker you just can’t use the Hyper-V version of it but you can use the VirtualBox version.

The issue where your Task Manager is showing Vritualisation is Disabled is something that is enabled in your computer BIOS (UEFI likely) on boot up of your laptop.

Some tips:

  • Windows 10 (8 and 8.1 also I think) does not shut-down like former version of Windows you need to press and hold shift whilst you shutdown which will allow your laptop to clean boot and allow access in to your BIOS to enable Virtualisation.

You’ll need to refer to your laptops manual for the specifics but this may help:

  • From a clean boot (see note above)
  • Repeatedly press Esc key at startup.
  • Press the F10 key for BIOS Setup.
  • Press the right arrow key to System Configuration tab, Select Virtualization Technology and then press the Enter key.

Good luck and have fun!


Sorry for this delayed reply but thanks so much.

Ok immediately ran in to problems. I was able to enable the Virtualization from BIOS and then installed Docker Terminal. First that its not able to detect any IP and for any command run keeps on telling me that “Something went wrong ruing an SSH command” or “An error occurred trying to connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/version: open //./pipe/docker_engine: The system cannot find the file specified.”

I am also confused by the version result. While installation I recall that a new version 1.13.0 of Boot2Docker.iso file was downloaded and installed, but the Docker version is still 12.x (unless it has got no relation to the iso file version).

I tried deleting this VM “Defaut” and then hit Docker Terminal again, which said that its gonna create the machine for me now, but then after a while told me “Error in driver during machine creation: This computer doesn’t have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory.” Is there an issue with the VirtualBox installation on my machine?

Would appreciate help to get over these roadblocks.

I guess Docker doesn’t support Windows 10 Home anymore :frowning:

You can install Docker Toolbox on Windows 10 Home:


Docs says Windows 10 Home does not support Hyper-V above, but my system seems to. See:

@friism could you address this conflicting information? I am about to try it out and let you know if I run into any problems or not.

I’m thinking either

  1. this documentation is outdated and Windows Insider latest version does support, hyper-v
  2. I may have flashed an illegitimate windows image with autokms on this machine & perhaps the information in screenshot is incorrect
  3. MSI did something to allow this?
1 Like

@friism any update to this thread? I have Thinkpad carbon X1/Windows 10 home edition. I also see Hyper-V params set to Yes as @aperk mentioned. I am unable to install Docker CE with the same error message.
One workaround I tried was to use choco package manager. Even that didn’t install docker daemon.
Any pointer is appreciated.

Same goes for me. LENOVO Legion Y520, Home edition. Virtualisation enabled, yet still unable to install DOCKER CE.

Any update here? To put it frankly, using Docker Toolbox/with VirtualBox sucks compared to Docker for Windows. Is there a way to feature detect Hyper V support without basing it on the OS version?

Gotta agree. My computer can run VMs no problem, but just because it’s using Win10 Home it can’t run Docker? Under Ubuntu live image it works fine, so it’s definitely not a hardware issue. And Hypervisor support is enabled under Programs and Features.

I’m hitting the same problem. Running win 10 home on a laptop that’s more than capable of running virtual machines. I’ve also tried going down the route of using Docker Toolbox, but this throws up a similar sounding error when starting the Quickstart Terminal (see attached). It’s annoying - one option is to use another VM tool (like Vagrant), and run Docker within this. The other option is to install Ubuntu and just move over to that. The latter is a very tempting option! Any advice welcome :slight_smile:dockerterm

Did you check your BIOS settings?

Hi Mario,
Yep I checked the BIOS, ensured virtualization was enabled and secure boot disabled. I also checked within Windows (Task Manager -> Performance tab), and checked that Windows was displaying ‘Virtualization - enabled’. I tried playing with both of these settings, but saw no difference in the output.
As an update - I installed Kubuntu and have now migrated to that entirely as my new development workspace. Zero complaints, and it runs Docker out of the box!

And ?
Any plans to fix this.

If this: is still valid, it can’t be fixed.

It is not valid. I have created an Issue on their GitHub Docs repository.

I have a Windows 10 Home on my notebook, and by doing systeminfo this is what I get:

Hyper-V Requirements: VM Monitor Mode Extensions: Yes
Virtualization Enabled In Firmware: Yes
Second Level Address Translation: Yes
Data Execution Prevention Available: Yes


Correct me if I am wrong, but that means my system is perfectly capable of running a Docker for Windows, but the only thing preventing me is the installer itself.

to be honest, i never thought that i would run into problems trying to install docker on win 10 home. maybe because i’m now on post cycle therapy supplements so my focusing is damaged? can someone help me more? thanks a bit of guidance would be appreciated.

I have the same thing, but I also noticed that Hyper-V has to be enabled. As in, if your copy of Windows 10 has Hyper-V, you can install it by simply enabling it because it’s already there. On Windows 10 Home, though, there is no Hyper-V to enable. I checked. I also have Windows 10 Home. The only option for Home edition users is to use Docker Toolbox. So yes, this is still valid.

Same here! I have a full Hyper-V support on Windows 10 Home and I’ve already ran docker on my machine before.