Invalid tar header while running compose with jenkins

Hello , my Jenkins has my github project ‘app’ containing docker-compose.yml file pulled inside jenkins default workspace. As execute shell step, it is supposed to run docker-compose up -d --build during build job. It failed once (if I remember well, it was caused by my mistake, forgot to provide file needed by one of Dockerfiles in COPY), and since than I keep getting following error:

  • docker-compose up -d --build
    Creating network “app_default” with the default driver
    Building some-service
    Error processing tar file(archive/tar: invalid tar header):
    Build step ‘Execute shell’ marked build as failure
    Finished: FAILURE

I googled it, but what i found seems to be unrelated. I tried removing everything by system prune, then I also removed all docker images from host and pulled them again. I am able to normally run docker-compose up as user when app is in home directory of user, but when i try to run it inside jenkins workspace I get the same error about tar file.

Any help appreciated

Ubuntu 16.04
docker-compose version 1.14.0-rc2, build 24dae73
Docker version 17.03.1-ce, build c6d412e
Jenkins 2.46.3

home user and jenkins are both in docker group