Docker Community Forums

Share and learn in the Docker community.

Laradock 404 on attempting to access PHP container

I posted this on reddit before I found this forum, but here it is anyway:

There are lots of moving parts in this, so where it is going wrong is still a little unclear to me. What the equivalent to the Docker menus that are talked about everywhere on the Docker Tools for Windows 7 is, I really don’t know. The problem just could be that I need to install something else. Or maybe Windows 7 is no longer supported, so once Docker stops working, tough luck?

My setup:

  • Windows 7 Pro
  • MS Docker Toolkit (no GUI, just Docker Quickstart terminal)
  • Laradock in a Lumen application using containers php-fpm, nginx, redis, workspace
  • Oracle Virtualbox as the VM running whatever flavour of Linux Laradock pulls in

So, this worked for a while, then I needed to move the application to a different local directory - was under C:\Users\Me\Github\ProjectA now under C:\Projects\ProjectA .

Everything appears to start correctly, but I get the 404 when attempting to connect (docker machine on 192.168.99.101).

$ docker-compose up -d nginx redis php-fpm workspace
Creating network "agg\_frontend" with driver "bridge"
Creating network "agg\_backend" with driver "bridge"
Creating network "agg\_default" with the default driver
Creating agg\_redis\_1            ... done
Creating agg\_docker-in-docker\_1 ... done
Creating agg\_workspace\_1        ... done
Creating agg\_php-fpm\_1          ... done
Creating agg\_nginx\_1            ... done

The workspace container does not have the application mounted in it, and I guess neither does the php-fpm container, hence the 404.

I am assuming this is my problem, which seems to be backed up by many people having the same problem and using this solution:

http://laradock.io/#i-get-nginx-error-404-not-found-on-windows

However, the solution talks about doing some action in the “shared drives tab”. The tab of what? I don’t have any Docker GUI, no “tabs”, no shared drives that I can see. How do I apply this solution - reset the shared drives (or the “docker shared drivers” as many other posts seem to state)? I seem to have hit a brick wall.

Any clues? Thanks!

I got my answer.

In VirtualBox (my VM controller) for the “default” VM (created by, and used by laradock) I needed to mount a shared directory. So host machine C:\Projects is mounted to /c/Projects in the VM through the settings. And that was it - everything just worked after that.

The Docker Quickstart shell sees the project in the host machine as being under /c/Projects too, so I guess (I assume) that so long as the same directory structure for the projects is visible from both within the VM and within the host machine, then laradock will be able to set up the containers in the VM and join everything together correctly (it does all its own VM-to-container file system mounts without any input from me).