Login failed "you must be a member of organization"

I’m running docker desktop on windows with wsl2, somehow today i suddenly logged out from my docker desktop, i tried to login with different account and new account this is what it says

sure im not in any organization as I also tried free and new account and it failed with same error.
Please help., thanks

Same issue here. Are free personal accounts being restricted, so we are unable to use Docker Hub without paying?

I tried to log in with my free test account and worked so it was either a temporary issue or the issues doesn’t happen with every account and and only the Docker support could help you or you can try Hub Feedback:

Are you trying to log in with the latest Docker Desktop? I tried with v4.20.1

Yes, this is for the latest Docker Desktop with a free account that is not in an organization. Also, issue is still happening. See issue, Login failed “You must be a member of the organization. Log in with a different account, or contact your organization owner to add your account.” · Issue #2330 · docker/hub-feedback (github.com)

I don’t know if this is happening only on my machine or not, but for now connecting to docker is impossible using my home wifi network, so I use tethering (hotspot) from my phone and it works well. After logging in I am able to do like pull image, push and everything. But when i change back to wifi it happens again. I think its because my internet service provider problem