Docker Community Forums

Share and learn in the Docker community.

Looks like something went wrong in step 'Finalize'... (Windows 7)


(Scottagillette) #1

I’m unable to get Docker Quick Start to finish successfully. Docker Toolbox 1.11.1 on Windows 7 64 Bit with 5.0.16 (?) and tried 5.0.20 of Virtual Box.

##Last part of VBox.log lists…


00:00:18.406983 VMMDev: Guest Log: vboxguest: misc device minor 56, IRQ 20, I/O port d020, MMIO at 00000000f0400000 (size 0x400000)
00:00:23.400935 NAT: Link up
00:00:37.627894 VMMDev: Guest Log: VBoxService 5.0.18 r106667 (verbosity: 0) linux.amd64 (Apr 18 2016 15:31:59) release log
00:00:37.627911 VMMDev: Guest Log: 00:00:00.000067 main Log opened 2016-05-09T16:59:47.845700000Z
00:00:37.629266 VMMDev: Guest Log: 00:00:00.001632 main OS Product: Linux
00:00:37.629298 VMMDev: Guest Log: 00:00:00.001668 main OS Release: 4.4.8-boot2docker
00:00:37.629323 VMMDev: Guest Log: 00:00:00.001694 main OS Version: #1 SMP Mon Apr 25 21:57:27 UTC 2016
00:00:37.629347 VMMDev: Guest Log: 00:00:00.001718 main Executable: /sbin/VBoxService
00:00:37.629353 VMMDev: Guest Log: 00:00:00.001719 main Process ID: 2317
00:00:37.629356 VMMDev: Guest Log: 00:00:00.001719 main Package type: LINUX_64BITS_GENERIC
00:00:37.634560 VMMDev: Guest Log: 00:00:00.006918 main 5.0.18 r106667 started. Verbose level = 0
00:00:37.640525 VMMDev: Guest Log: 00:00:00.012804 vminfo rtldrNativeLoad: dlopen(‘libdbus-1.so.3’, RTLD_NOW | RTLD_LOCAL) failed: libdbus-1.so.3: cannot open shared object file: No such file or directory
00:00:37.640571 VMMDev: Guest Log: 00:00:00.012863 vminfo Error: Unable to connect to system D-Bus (1/3): D-Bus not installed
00:00:37.980532 NAT: IPv6 not supported
00:00:38.590173 NAT: DHCP offered IP address 10.0.2.15
00:00:38.590938 NAT: DHCP offered IP address 10.0.2.15
00:00:38.590948 NAT: Guest address guess set to 10.0.2.15 by DHCP ACK
00:00:40.681081 NAT: Old socket recv size: 64KB
00:00:40.681101 NAT: Old socket send size: 64KB
00:00:42.640196 VMMDev: Guest Log: 00:00:05.013521 vminfo Error: Unable to connect to system D-Bus (2/3): D-Bus not installed
00:00:47.642123 VMMDev: Guest Log: 00:00:10.015306 vminfo Error: Unable to connect to system D-Bus (3/3): D-Bus not installed
00:01:30.398935 NAT: DNS#0: 10.40.70.196
00:01:30.398952 NAT: DNS#1: 10.25.4.55
00:01:30.398956 NAT: DNS#2: 10.25.10.199
00:01:30.398959 NAT: DNS#3: 168.146.1.196
00:01:30.398962 NAT: DNS#4: 10.40.18.198
00:01:30.398965 NAT: DNS#5: 10.25.4.111
00:01:30.398968 NAT: DNS#6: 10.40.200.71
00:01:30.398970 NAT: DNS#7: 10.25.10.198
00:01:30.398973 NAT: DNS#8: 10.40.200.198


(Ochriste) #2

chance are it is only the interactive shell that doesnt work.

open Virtualbox, you should see a “default” VM, thats the docker VM, it should be running.
if you click on the Virtualbox console preview, you should see the VM console with the Docker logo etc (if you only see a black windows, just type enter, that should refresh the console content.)
if the VM is running, you can log into it using putty, with the ip which has been indicated on screen when you executed the Docker Quickstart Terminal.
If you forgot what it was, you can always do a “ifconfig | less” in the console through Virtualbox.
Mine was 192.168.99.100
Now simply ssh to that ip with putty and use the docker/tcuser login/password

My guess is the interactive console fail to correctly open with autologin, and we only see the “Looks like something went wrong in step ‘Finalize’” message

I hope this help


(Fengge) #3

多谢~和我遇到的情况一样,打开VM果然有个虚拟机再跑,用那个IP登进去就可以了


(Hannes0x21) #4

Probably a little late now, but I had the exact same error and for me the following helped:

In your docker toolbox installation folder, edit start.sh:

In the Finalize step, there is a clear command (for version 1.12.2, it was in line 74). Comment that out:

STEP="Finalize"
#clear
cat << EOF
...

That’s where the startup was choking on. No idea, why.

Also, you might want to check if your export path is matching your installation location (line 8).

Best regards,
Hannes


(Bjacques) #5

I had the same errors. I am on Windows 10 Home edition and this is what I had to do to get it to work…

  1. I couldn’t get the latest version of VirtualBox to execute, so I downgraded to v4.3.12 which works fine

  2. The “Docker Quick Start” icon is executing the script installed at C:\Program Files\Docker Toolbox\start.sh so I edited this to ensure it was finding my installation of Virtual Box

export VBOX_MSI_INSTALL_PATH=/d/tools/Oracle/VirtualBox/

  1. The following line in start.sh was also causing an error which seems to be a problem in how it executes in windows bash as it raises an error flag and you get the message > “Looks like something went wrong in step Checking status on default…”

VM_STATUS="$(${DOCKER_MACHINE} status ${VM} 2>&1)"

So change this line not to redirect output, so it looks like this

VM_STATUS="$(${DOCKER_MACHINE} status ${VM})"

Now everything works and I can click on the “docker quick start” icon and it brings up the docker terminal.

Note: You should be able to open VirtualBox icon and see a new VM installed named “default” and it has a status of “Running”


(Supersue) #6

For me the issue was that I have Cygwin Bash installed and it’s .bashrc and .bash_functions present in my Windows home directory.

These set up an alias for “cd”, and the cd_func that it called made the error trap think an error had occured.

So before the “cd” line, I inserted “unalias cd”.


(Thedavil) #7

PERFECT!! Thanks hannes0x21 , your comment fix worked for me. Windows 7 / Docker Toolbox 1.11.0


(Dprmiles) #8

Commenting out the ‘clear’ before the ‘cat’ of the docker whale solved it for me.