Docker Community Forums

Share and learn in the Docker community.

Made stupid mistake in uninstalling!


(Danielwsc) #1

I’m on
Windows 10
and just (5 Oct 2017) downloaded the Windows Installer.
On re-boot, Docker couldn’t run.

So I used this script


to uninstall Docker and it uninstalled Docker! Only thing is that it left the entry in the Apps on Settings.
Yes I just now noticed the osx but surprise, my Windows Powershell ran with it no problems.

Then when I tried to re-install Docker, it said that something was up-to-date and the re-install stopped without doing anything.
Then I re-booted the system and re-downloaded another Windows installer, same thing.

Now I am stuck with a docker entry on my app settings and no docker. I would rather have a functioning docker but if not, as I am a Docker noob and have no time to learn how to trouble-shoot a non-working obviously complicated piece of software, no Docker at all.

I think I can remove the app setting entry with regedit but thought that I would seek some advice before going off again half-cocked.

Please help.

edit:
P.S. There are no regedit entries so I guessed the uninstall worked! Only thing is that the entry is still on the App Settings.
P.P.S. Used this … http://www.glarysoft.com/absolute-uninstaller/


(Pridocimage) #3

Hi @danielwsc, I am facing the similar issue. Please let me know if you have found the solution for this.


(John0022) #4

hey there, am too facing the same problem. Hope you will help me in sorting out my problem too. Thanks in advance @john0022
Appschip Kissanime Mobile


(Niknot) #5

Same issue.
There must be something specific that the installer uses to come to the faulty conclusion “existing installation is up to date”. Question is what that ‘something’ is…
image

I’ve got nothing Docker-related in:

  • C:\Program Files\Docker
  • ~/AppData
  • Registry (as far as I can see)