Docker Community Forums

Share and learn in the Docker community.

Can't upgrade/uninstall for missing file in user temp directory


(Cvalerio77) #1

Expected behavior

Should uninstall via control panel Programs and features

Actual behavior

The uninstall process starts but after a short while states that cannot continue due to a missing tmpBA42.msi file in C:\Users{myuser}\AppData\Local\Temp\

Information

Antivirus have been disabled. Probably due to system disk clean up.

Steps to reproduce the behavior

  1. Perform a disk cleanup and delete temporary files
  2. Launch Docker for Windows uninstall process via Control Panel > Programs and Features

(Emmanuel Briney) #2

Hi,

sorry I tried to reproduce this bug but everything was ok for me and the app was uninstalled as expected.
I checked everything was deleted in Temp dir.before.

Did you upgrade from a previous version?


(Psyrez) #3

Same here -

First of all, avast complain about the installer

If I disable it - it is asking for

tmpA2C.msi

on C:\Users{userName}\AppData\Local\Temp\

which was probably deleted by avast or disk cleanup


(Cvalerio77) #4

Hi @ebriney,

yes, I think this version is an upgrade from the previous (i like to stay updated).

Since automatic uninstall process fails, manual uninstall instruction would be a nice to have :smiley:.

Thanks

ADDENDUM: 1.12.0-rc2-beta16 (build 4760) is my current version.


(Mark L) #5

I have the same issue. I no longer have the installer for the currently installed version (1.12.0-RC2-BETA17 build 5022) and I can’t uninstall that version using the new installer (1.12.0-RC3-BETA18 build 5193).

I second @cvalerio77’s request for manual installation instructions.

Is the source available for Docker for Windows?


(Emmanuel Briney) #6

Thanks guys, I will try to uninstall from an upgrade after cleaning temp folder.

@mlapierre: Docker for Windows sources are not available for now

I will add manual uninstall procedure in the troubleshooting section.

Can you help me on that? because for now I cannot reproduce the state you are in.

First step: try to destroy the vm using C:\Program Files\Docker\Docker\resources\MobyLinux.ps1 -Destroy
(check that vm is not anymore there, Get-Vm in powershell or hyperv manager) then try to uninstall

Second step: kill Docker.Service, try to uninstall

Third step: remove manually, delete C:\Program Files\Docker, the uninstall settings panel should detect that the directory has been deleted when you will click on uninstall else you’ll need to remove it manually with regedit


(Mark L) #7

Thanks @ebriney.

I just tried those steps, but unfortunately I still have the same problem; the (un)installer prompts for the location of InstallDocker.msi, and won’t accept the location of the latest installer.

You may be able to reproduce the error by upgrading from the standard build 10586 to a Windows Insider Preview build. I switched to the Fast channel, which is when things went awry. I don’t know if that’s just a coincidence.


(Mark L) #8

I was able to reinstall successfully after deleting a few registry keys. I deleted these, in order, attempting the reinstall after deleting each:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall (and then find the key relevant to docker)
HKEY_USERS\S-1-5-21-3319356852-480035188-4189491591-1001\SOFTWARE\Docker Inc.
HKEY_CLASSES_ROOT\Installer\Features\14CAFFD005D2C7742B25F7E313CED407
HKEY_CLASSES_ROOT\Installer\Products\14CAFFD005D2C7742B25F7E313CED407

Funnily enough, after installing build 5193 I was prompted to upgrade to build 5226, and that worked fine, so I suspect (at least for me) the problem was the switch to the Insider Preview build.


(Emmanuel Briney) #9

Thanks you for your feedback, I think we will have to test it.On the last version we improved the vm stopping/destroying code so perhaps it’s enough to solve the problem you met.


(Cvalerio77) #10

Hi All,

just like @mlapierre I have been able to reinstall Docker after deleting registry keys and all the files from previous setup.

Case closed, but this fallback procedure should be included in uninstaller/upgrade, IMHO.

Thanks,

Claudio