Docker Community Forums

Share and learn in the Docker community.

Manifest not found


(Creditunionsa) #1

Hi Docker Community!

I am just getting started with Docker and am trying to build a new image using an existing image using the FROM command in my Dockerfile.

My Dockerfile is pretty simple - it looks like this:

# Pull base image from circle ci image
FROM circleci/node:latest-browers

# Install aws cli
RUN sudo apt-get update -qq && sudo apt-get install -y postgresql python-pip python-dev build-essential
RUN sudo pip install --upgrade pip
RUN sudo pip install --upgrade virtualenv
RUN sudo pip install awscli

But when I run docker build -t my-image . I get the following error:

manifest for circleci/node:latest-browers not found

Any help would be appreciated!


(David Maze) #2

Did you mean “browsers”, with two "s"s? (https://hub.docker.com/r/circleci/node/tags/ lists all of the tags for that image and many of them are “browsers”.)


(Creditunionsa) #3

Haha! yes. Good old typo. I just figured it out. Thanks for your help though :slight_smile:


(Sam) #4

shouldn’t that be (notice the extra s)

circleci/node:latest-browsers

(Steere888) #5

Hi,
I am seeing the same error when I try to pull to anything from my docker on Windows 10 app.