Docker Community Forums

Share and learn in the Docker community.

Option to enable wsl2 greyed out, but my wsl was wsl2


Hello,

I have Docker Desktop running on Windows, but now would like to enable the WSL2 functionality. I enabled support for experimental features, but the WSL2 checkbox is greyed out. Windows subsystem for Linux is installed, as are all necessary Hyper-V features.

Any suggestions on what to do?

Thanks.

I believe that means that you are using WSL 2. To verify, check the Resources, WSL Integration tab. If it allows you to select a default WSL 2 distro, you are using WSL 2.

Thanks for your help!
Now I’m ensure I using WSL2.