Docker Community Forums

Share and learn in the Docker community.

Docker resources [You don't have any WSL 2 distro. Please convert a WSL 1 distro to WSL 2]

Despite the fact I have installed two distros in my windows 10

PS C:\Users\sdancer> wsl -l -v                                                                                            NAME            STATE           VERSION
* Ubuntu-20.04    Stopped         2
  Ubuntu-18.04    Stopped         2
PS C:\Users\sdancer> ]

Under Resources & WSL INTEGRATION I get the message " You don’t have any WSL 2 distro. Please convert a WSL 1 distro to WSL 2, or install a new distro and it will appear here. More info"

Why?

Uninstall your distros, ensure Hyper-V is enabled, and WLS2 is enabled, and reinstall your distros.
Worked for me.

@sdancer75 Maybe you just did forget one step of the installation process?

I myself missed one important point during installation of Docker Desktop for Windows and had the same problem that you describe: My Ubuntu distro did not appear in Docker Resources settings and it stated that I wouldn’t have any WSL 2 distros (which was obviously not correct).

Fortunately (for me) it was not necessary to uninstall and reinstall the Ubuntu distro - there is a much easier way:

I could resolve this issue for me by adding my Windows user account to the group docker-users - just as it says in the installation instructions for Windows:

If your admin account is different to your user account, you must add the user to the docker-users group. Run Computer Management as an administrator and navigate to Local Users and Groups > Groups > docker-users . Right-click to add the user to the group. Log out and log back in for the changes to take effect.

After doing that, everything worked as expected and I was able to see my Ubuntu in Docker settings as a WSL2 distro.

So before trying anything other you should first check if your user is a member of the group docker-users.

thank you for your question.
it makes me know more.
Merchant crypto

Thanks !!

I already solved the problem. The 1st step I had to do was to upgrade my Win10 from home to Pro which supports HyperV. Then I uninstalled docker and re-installed it again.

Best Regards,

Thank you for the information.
a good way to solve the problem.
Merchant crypto