Pushing to docker hub - one layer stucks

Hello everybody,

I try to push a image to docker hub. Unfortunatelly, the push stucks at a certain layer. I already set “max-concurrent-uploads”: 1, but this is not working, too. Any suggestions?

Thanks a lot.

06058b63bc5a: Layer already exists
680dc2e55950: Layer already exists
6f279f52b4dd: Layer already exists
26ba01bb9954: Layer already exists
22abe498f6a6: Layer already exists
5f178fae1eca: Layer already exists
d8a0b8c8afd2: Layer already exists
a0e2013dfd15: Layer already exists
f740af656a0e: Layer already exists
499b31d5b7ff: Layer already exists
8f0354b1a752: Layer already exists
efedf62c9b0a: Pushing [==================================================>] 108.6MB
702c02d7ea3f: Waiting


Have you tried it later again? Is it waiting every time you try? When layers exist Docker does not need to send much data to the registry. Non-existing layers need a stable network. If you are on an unstable network like wifi, it can slow the uploading down or even stop it. Other known issue is that Docker Desktop has more problem with networking than Docker CE on Linux. When I used Docker in an UTM virtual machine that was unstable too probably because I did not configure UTM properly. I tried later and it worked. If it never works, then It can be a firewall issue too.

Yea, always the same result. But I figured out that this is related to my firewall. Don’t know why just certain parts are not working, but deactivating the firewall was doing the trick. Thanks for your help.