Docker Community Forums

Share and learn in the Docker community.

[solved] Docker beta conflicts with Virtualbox

beta
virtualbox

(Adrian Jimenez-Galindo) #1

Expected behavior

Should not conflict with existing virtual machines

Actual behavior

When Docker (beta) is installed, no 64-bit virtual machines in Virtualbox can be run.

Information

  • Error is that VT-x is not available (VERR_VMX_NO_VMX) in the system.
  • Windows 10, Docker beta, virtualbox 5.0.20, same error in Ubuntu (64bit) and CentOS (64 bit)
  • The error is to be expected, but I’d argue that there’s a better workaround than going to the console to kill Hyper-V every time one wants to start up a virtual machine.

Steps to reproduce the behavior

  1. Create a 64 bit virtual machine
  2. Install docker beta
  3. Try to run the machine.

I’ll be posting this same error in the forums related to virtualbox.


(Michael Friis) #2

This is a known limitation of Hyper-V and VirtualBox, see the FAQ: https://beta.docker.com/docs/windows/faqs/

VirtualBox already has a ticket to track this: https://www.virtualbox.org/ticket/12350


(Adrian Jimenez-Galindo) #3

Aw man, I thought I had found a good contribution. I’ll take a look at the links – thank you!